Bug 844252 - vip field is not removed from mongodb for an existing user after server upgrade and migrate
vip field is not removed from mongodb for an existing user after server upgr...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 02:25 EDT by Jianwei Hou
Modified: 2015-05-14 22:02 EDT (History)
1 user (show)

See Also:
Fixed In Version: devenv_1922
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 16:42:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-07-30 02:25:45 EDT
Description of problem:
After upgrade and migrate, the existing vip user has small and medium gear sizes, and can create apps of medium gear size, but the vip field in mongodb for the user is not removed

Version-Release number of selected component (if applicable):
On devenv-stage_226 

How reproducible:
always

Steps to Reproduce:
1.Lauch an old instance, currently devenv-stage_226
2.Create user, set vip for the user
  rhc-admin-ctl-users --setvip true -l jhou@redhat.com
3.Prepare test data
4.Upgrate devenv to latest
  yum update
5.git clone git@github.com:openshift/li.git
  cd li/misc/maintenance/bin
  ./migrate-mongo-2.0.15
  rhc-admin-migrate --version 2.0.15
6.Check user status after upgrade and migrate
7.Enable node profile, change node profile to medium, and create apps of medium gear size with the existing account

  
Actual results:
After step 6:
[root@ip-10-140-76-214 repo]# rhc-admin-ctl-user -l jhou@redhat.com


User jhou@redhat.com:
      consumed gears: 33
           max gears: 50
          gear sizes: small, medium

Check app status in mongodb
PRIMARY> db.user.findOne({_id:"jhou@redhat.com"})
    ..................
	],
	"uuid" : "dfaabe26c1a1489897c4a039dd1fd607",
	"vip" : true
}

The "vip" field is not remove in mongodb

After step 7:
Apps were created successfully, use rest api the get app's gear size, it was medium 
<?xml version="1.0" encoding="UTF-8"?>
<response>
  <type>gear_groups</type>
  <data>
    <gear-group>
      <gear-profile>medium</gear-profile>
      <cartridges>
        <cartridge>
          <name>perl-5.10</name>
        </cartridge>
      </cartridges>
.......

Expected results:
The "vip" field shoud be remove from mongodb

Additional info:
Because user has medium gear size and is able to create medium gears, only the "vip" field remains in mongodb, so set a low severity for this bug.
Comment 1 Jianwei Hou 2012-07-30 05:58:24 EDT
I launched a new instance and reproduced this problem again. 

Steps:
1.Create 3 accounts, set vip for all of them
2.Upgrade and migrate, steps are same with above description
3.Run rhc-admin-ctl-users to check users gears size, user have small and medium gear size.
4.log into mongodb, and check user status from mongo shell, and found:
  the first user still have vip field remained in mongodb
  the second and third user have vip field removed from mongodb
Comment 2 Jianwei Hou 2012-07-31 01:45:21 EDT
Verified on devenv_1922

Steps:
1.Launch an old instance, currently devenv-stage_226, Create 4 user accouts, setvip for 3 of them, and 1 account remains normal
2.Prepare test data
3.Upgrade and migrate
  yum update
  git clone git@github.com:openshift/li.git
  cd li/misc/maintenance/bin
  ./migrate-mongo-2.0.15
  rhc-admin-migrate --version 2.0.15
4.Check account status using rhc-admin-ctl-user, the previous vip users have medium gear size
5.Check account status in mongodb, the vip field is removed from mongodb
6.Enable node profile and change node profile to medium
7.Try to create app of medium gear size, Creation was successful

Note You need to log in before you can comment on or make changes to this bug.