Bug 844267 - Changes to an old existing jbossas application is not deployed after git push
Summary: Changes to an old existing jbossas application is not deployed after git push
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Containers   
(Show other bugs)
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Bill DeCoste
QA Contact: libra bugs
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-30 07:24 UTC by Jianwei Hou
Modified: 2015-05-14 22:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 20:42:17 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jianwei Hou 2012-07-30 07:24:41 UTC
Description of problem:
Make changes to an old existing scalable/non-scalable jbossas-7 application, and git push. Changes are not deployed when accessing url.

Version-Release number of selected component (if applicable):
On devenv-stage_226

How reproducible:
always

Steps to Reproduce:
1.Lauch an old instance currently devenv-stage_226
2.Prepare account and test data, create jbossas-7 and jbosseap-6.0 apps including scalable and non-scalable type
3.Upgrage server to latest and run rhc-admin-migrate
4.Make some changes to app's repo, eg. edit index.html so the changes are visible when accessing app's url
5.git push changes to remote repo
6.Access app's url


Actual results:
git push was successful, the changes are not deployed when accessing app's url

Expected results:
git push was successful, and changes are deployed when accessing app's url


Additional info:
ssh into application, check the remote repo, and changes are made, which mean git push was successful, but the changes are not deployed.
I manually restarted this application but the problem was still there
Create new jbossas-7 applications, change, git push and access app's url, very thing working fine, changes are deployed.

Comment 1 John Poelstra 2012-07-31 17:08:16 UTC
expect to have a fix today

Comment 2 Bill DeCoste 2012-07-31 23:39:46 UTC
Fixed perms for JAVA_HOME

Comment 3 Jianwei Hou 2012-08-01 06:11:11 UTC
Tested it on devenv_1931, after git push, changes are still not deployed

Steps:
1.Lauch an older instance, devenv-stage_226
2.upgrade and migrate
3.go to app's repo, make some change, eg modifying the index.html so the changes are visible via website. Then git push
4.Open app's website, and no changes are deployed.
5.shh into application, check changes under app-root/repo, chanages are consistent with my local repo. But the app's website did not show any changes. Restart and reload app, problem is still there.

This problem exists only with an existing jbossas application after upgrading an old instance.

Comment 4 Bill DeCoste 2012-08-01 15:48:04 UTC
Do you have an existing devenv I can log into to see what's going on?

Comment 5 Bill DeCoste 2012-08-01 16:11:04 UTC
What exactly are you running to perform the upgrade/migration?

Comment 6 Bill DeCoste 2012-08-01 17:20:50 UTC
Been able to recreate. Changes are not in ./8762244262ae4f2dae1f377bfb54845f/jbossas-7/jbossas-7/standalone/tmp/vfs/temp6c59feb90932982f/ROOT.war-d0552488d82b1905

Comment 7 Bill DeCoste 2012-08-01 18:06:48 UTC
In new apps /jbossas-7/jbossas-7/standalone/deployments is a link to app-root/repo/deployments but in old apps it's a copy. Builds update the latter but deployments happen from the former. So we always deploy the original ROOT.war. 

Look like we need to update the migration script to switch from copy to link.

Comment 8 Bill DeCoste 2012-08-01 18:55:21 UTC
Updated rhc-admin-migrate and migrate.rb

Comment 9 Jianwei Hou 2012-08-02 05:42:52 UTC
Verified on devenv_1933

Steps:
1.Lauch an older instance, devenv-stage_226
2.upgrade and migrate
3.go to app's repo, make some change, eg modifying the index.html so the changes are visible via website. Then git push
4.Open app's website, changes are deployed.

Fixed


Note You need to log in before you can comment on or make changes to this bug.