Bug 844283 - [engine-core] fix of job messages that uses SnapshotName object
[engine-core] fix of job messages that uses SnapshotName object
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Liron Aravot
Leonid Natapov
storage
:
: 848363 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 04:11 EDT by Haim
Modified: 2016-02-10 11:36 EST (History)
11 users (show)

See Also:
Fixed In Version: SI19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:04:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haim 2012-07-30 04:11:40 EDT
Description of problem:

when trying to remove snapshot where disks are gone (removed before), I get the following exception:

2012-07-29 20:56:49,287 WARN  [org.ovirt.engine.core.dal.job.ExecutionMessageDirector] (ajp-/127.0.0.1:8009-15) [2c369c68] The message key RemoveSnapshot is missing from bundles/ExecutionMessages
2012-07-29 20:56:49,388 INFO  [org.ovirt.engine.core.bll.RemoveSnapshotCommand] (ajp-/127.0.0.1:8009-15) [2c369c68] Lock Acquired to object EngineLock [exclusiveLocks= key: 9c9bc1f1-8f90-4464-bfb4-0bf73a478c74 value: VM
, sharedLocks= ]
2012-07-29 20:56:49,392 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.IsValidVDSCommand] (ajp-/127.0.0.1:8009-15) [2c369c68] START, IsValidVDSCommand(storagePoolId = 77887fd1-3408-44ec-8de4-153948d89cdc, ignoreFailoverLimit = false, compatabilityVersion = null), log id: 1509eea8
2012-07-29 20:56:49,393 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.IsValidVDSCommand] (ajp-/127.0.0.1:8009-15) [2c369c68] FINISH, IsValidVDSCommand, return: true, log id: 1509eea8
2012-07-29 20:56:49,630 INFO  [org.ovirt.engine.core.bll.RemoveSnapshotCommand] (ajp-/127.0.0.1:8009-15) [2c369c68] Running command: RemoveSnapshotCommand internal: false. Entities affected :  ID: 9c9bc1f1-8f90-4464-bfb4-0bf73a478c74 Type: VM
2012-07-29 20:56:49,777 INFO  [org.ovirt.engine.core.bll.RemoveSnapshotCommand] (ajp-/127.0.0.1:8009-15) [2c369c68] Lock freed to object EngineLock [exclusiveLocks= key: 9c9bc1f1-8f90-4464-bfb4-0bf73a478c74 value: VM
, sharedLocks= ]
2012-07-29 20:57:51,705 INFO  [org.ovirt.engine.core.bll.AsyncTaskManager] (QuartzScheduler_Worker-42) Setting new tasks map. The map contains now 0 tasks
2012-07-29 20:57:51,705 INFO  [org.ovirt.engine.core.bll.AsyncTaskManager] (QuartzScheduler_Worker-42) Cleared all tasks of pool 77887fd1-3408-44ec-8de4-153948d89cdc
Comment 1 Allon Mureinik 2012-07-31 03:23:32 EDT
patch in gerrit: http://gerrit.ovirt.org/#/c/6776/
Comment 2 Allon Mureinik 2012-08-01 09:12:52 EDT
patch was abandoned, the solution was incomplete.
Reassigning to Liron, who is handling a couple of those issues.
Comment 3 Itamar Heim 2012-08-15 09:39:23 EDT
*** Bug 848363 has been marked as a duplicate of this bug. ***
Comment 4 Liron Aravot 2012-09-04 10:43:42 EDT
submitted patch http://gerrit.ovirt.org/#/c/7745/ as a fix
Comment 5 Allon Mureinik 2012-09-11 12:28:29 EDT
Merged I43e1de508e53eaf624fd7fb3de455a80003c5cd6
Comment 6 Leonid Natapov 2012-10-02 07:32:51 EDT
si19. No internal error. getting backend error message.

Note You need to log in before you can comment on or make changes to this bug.