Bug 844303 - dracut-022-63.git20120727 is missing run-time dependency on kbd
dracut-022-63.git20120727 is missing run-time dependency on kbd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 916571
  Show dependency treegraph
 
Reported: 2012-07-30 05:13 EDT by Petr Pisar
Modified: 2016-11-24 06:57 EST (History)
5 users (show)

See Also:
Fixed In Version: dracut-043-67.fc23.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 916571 (view as bug list)
Environment:
Last Closed: 2016-11-24 06:57:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-07-30 05:13:11 EDT
# rpm -q dracut
dracut-022-63.git20120727.fc18.x86_64

# dracut --force 3.6.0-0.rc0.git2.1.fc18.x86_64
E: Directories consolefonts, consoletrans, keymaps, unimaps not found.  Please inform us about the issue including your OS name and version.

The tools for setting Linux VT font and keymaps is kbd-misc, but it's not required by dracut:

# rpm -q --requires dracut |grep kdb-misc
# echo $?
1

Proposed solution: Add `Requires: kbd-misc' to dracut.spec.
Comment 1 Petr Pisar 2012-07-30 05:19:39 EDT
After installing kbd-misc, the story continues:

# dracut --force 3.6.0-0.rc0.git2.1.fc18.x86_64
dracut-install: ERROR: installing 'setfont'
dracut-install: ERROR: installing 'loadkeys'
dracut-install: ERROR: installing 'kbd_mode'
E: /usr/lib/dracut/dracut-install -D /var/tmp/initramfs.vy6quY -a setfont loadkeys kbd_mode stty   

The executables are provided by `kbd' package. The kbd-misc delivers data only.

So, you should add `Requires: kbd'.
Comment 2 Harald Hoyer 2012-07-30 07:58:51 EDT
thanks!
Comment 3 Orion Poplawski 2013-02-19 11:08:53 EST
It would be nice if this got back-ported to F17 too.  I just ran into it there.
Comment 4 Orion Poplawski 2013-07-03 18:31:21 EDT
I just noticed that dracut in Fedora 19 no longer requires kbd.  Is this issue back?
Comment 5 Petr Pisar 2013-07-04 03:28:44 EDT
Yes. If I instinall kbd-misc, dracut start complain again.
Comment 6 Petr Pisar 2013-07-04 03:30:28 EDT
(In reply to Petr Pisar from comment #5)
> Yes. If I instinall kbd-misc, dracut start complain again.
If I uninstall kbd-misc, dracut will start to complain again.
Comment 7 Jan Kurik 2015-07-15 11:04:58 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 23 development cycle.
Changing version to '23'.

(As we did not run this process for some time, it could affect also pre-Fedora 23 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 23 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora23
Comment 8 Fedora End Of Life 2016-11-24 05:42:47 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Petr Pisar 2016-11-24 06:57:07 EST
dracut-043-67.fc23.x86_64 seems to be fixed.

Note You need to log in before you can comment on or make changes to this bug.