Bug 844360 - returns non-zero exit code when used with --help parameter
returns non-zero exit code when used with --help parameter
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: busybox (Show other bugs)
6.3
Unspecified Linux
unspecified Severity low
: rc
: ---
Assigned To: Denys Vlasenko
qe-baseos-daemons
:
Depends On:
Blocks: 1366045 1270638 1359574
  Show dependency treegraph
 
Reported: 2012-07-30 08:22 EDT by Tomas Dolezal
Modified: 2016-09-21 13:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-21 13:02:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dolezal 2012-07-30 08:22:39 EDT
Description of problem:
If any of applets is called with --help parameter, busybox returns exit code 1. 0 is expected because this option is implemented and documented as well.

Version-Release number of selected component (if applicable):
BusyBox v1.2.0 (2012.07.17-15:33+0000)

How reproducible:
Simply call with --help parameter
  
Actual results:
Exit code is 1

Expected results:
Exit code is expected to be 0
Comment 1 Denys Vlasenko 2012-08-15 09:23:59 EDT
I know how to fix this. I need ACKs.
Comment 2 RHEL Product and Program Management 2012-09-07 01:36:17 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.