Bug 844613 - i18n module fix to add keymap includes
i18n module fix to add keymap includes
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 03:50 EDT by Stefan Reimer
Modified: 2012-07-31 05:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-31 05:35:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Reimer 2012-07-31 03:50:13 EDT
Description of problem:
Due to bug in module-setup.sh in the i18n module includes from the main keymap are not working and not added to the initrd image.

Only one quotation per line is removed. Needs to remove all.
See attached patch.

Version-Release number of selected component (if applicable): 022


Fix/patch:

--- module-setup.sh.orig	2012-07-31 00:48:52.880874293 -0700
+++ module-setup.sh	2012-07-30 19:48:47.506794908 -0700
@@ -31,7 +31,7 @@
             *) cmd=grep ;;
         esac
 
-        for INCL in $($cmd "^include " $MAP | while read a a b; do echo ${a/\"/}; done); do
+        for INCL in $($cmd "^include " $MAP | while read a a b; do echo ${a//\"/}; done); do
             for FN in $(find ${kbddir}/keymaps -type f -name $INCL\*); do
                 findkeymap $FN
             done
Comment 1 Harald Hoyer 2012-07-31 05:35:56 EDT
Many thanks!

Note You need to log in before you can comment on or make changes to this bug.