Bug 844615 - While creating a new user validation for case-opposite same names should be provided
While creating a new user validation for case-opposite same names should be ...
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sammons
Tazim Kolhar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 03:54 EDT by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 14:06:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
create user name error (45.97 KB, image/png)
2012-07-31 03:54 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2012-07-31 03:54:55 EDT
Created attachment 601464 [details]
create user name error

Description of problem:
While creating a new user using SAM UI, user name of already created user but
of opposite case (Lower case or Upper Case) is accepted
 
Version-Release number of selected component (if applicable):
[root@nec-em16 ~]# rpm -qa | grep katello
katello-cli-common-0.2.45-1.fc16.noarch
katello-glue-foreman-0.2.50-1.fc16.noarch
katello-glue-pulp-0.2.50-1.fc16.noarch
katello-selinux-0.2.6-1.fc16.noarch
katello-certs-tools-1.1.6-1.fc16.noarch
katello-configure-0.2.32-1.fc16.noarch
katello-glue-candlepin-0.2.50-1.fc16.noarch
katello-all-0.2.53-1.fc16.noarch
katello-common-0.2.50-1.fc16.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-0.2.45-1.fc16.noarch
katello-0.2.50-1.fc16.noarch
katello-repos-0.2.7-1.fc16.noarch


How reproducible:
yum install katello-all thumslug
katello-configure --deployment=headpin

Steps to Reproduce:
1.Log in UI
2.Navigate to Administer
3.Go to + New User
4.Provide the username,password,default organisation,emailid
5 Make sure name is same as already taken but of opposite case (Upper Case or Lower Case)
6.Create User


Actual results:
User is created

Expected results:

Validation should be provided refraning from creating the user
Additional info:

screen shot attached
Comment 1 Eric Sammons 2012-08-17 14:06:51 EDT
Closing as not a bug as most organizations will have a process in place for creating users and we should permit the customer the greatest amount of flexibility here.  Keep in mind most modern authentication engines (pam, ldap etc...) are case sensitive.

Note You need to log in before you can comment on or make changes to this bug.