Bug 844644 - Replace brick doesn't work when the volume is stopped
Replace brick doesn't work when the volume is stopped
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 05:20 EDT by Rahul Hinduja
Modified: 2015-11-03 18:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 13:18:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Hinduja 2012-07-31 05:20:13 EDT
Description of problem:

Currently replace brick only works when the volume is Started. I think it should still alow the replace brick when the volume is stopped. In a general case if I wish there are no writes when I start the replace brick, I would stop the volume and will do a replace brick which is currently not supported.

Version-Release number of selected component (if applicable):
glusterfs 3.3.0rhs

How reproducible:
Always


Steps to Reproduce:
1.Stop the volume
2.Try to replace brick with the cli "volume replace-brick <VOLNAME> <BRICK> <NEW-BRICK> start"
  
Actual results:
[root@unused ~]# gluster 
gluster> volume replace-brick vol0 10.70.1.115:/root/bricks/b1 10.70.1.115:/root/bricks/b4 start
volume: vol0 is not started
gluster> 


Expected results:


Additional info:
Comment 2 Amar Tumballi 2012-10-05 13:18:50 EDT
this fails because replace-brick tries to do the data-migration... try replace 'commit force' for the expected behavior of yours...

Note You need to log in before you can comment on or make changes to this bug.