Bug 844645 - Please rebuild mod_wsgi against python 2.7.3
Please rebuild mod_wsgi against python 2.7.3
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: mod_wsgi (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 05:21 EDT by Jan Pazdziora
Modified: 2012-11-22 08:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 08:16:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2012-07-31 05:21:43 EDT
Description of problem:

It looks like python 2.7.3 landed in Fedora 16 updates. This leads to warning in Apache's error_log upon startup.

Version-Release number of selected component (if applicable):

# rpm -q python mod_wsgi
python-2.7.3-3.fc16.x86_64
mod_wsgi-3.3-1.fc16.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have Fedora 16 with httpd, python-2.7.2, and mod_wsgi. Observe that there are not warnings upon Apache start and the notice line says

[Tue Jul 31 10:16:48 2012] [notice] Apache/2.2.22 (Unix) DAV/2 mod_wsgi/3.3 Python/2.7.2 configured -- resuming normal operations

2. Run yum upgrade python, note that version 2.7.3 gets installed.
3. Run service httpd restart, look into /var/log/httpd/error_log.
  
Actual results:

[Tue Jul 31 10:17:44 2012] [warn] mod_wsgi: Compiled for Python/2.7.2.
[Tue Jul 31 10:17:44 2012] [warn] mod_wsgi: Runtime using Python/2.7.3.
[Tue Jul 31 10:17:44 2012] [notice] Apache/2.2.22 (Unix) DAV/2 mod_wsgi/3.3 Python/2.7.3 configured -- resuming normal operations

Expected results:

[Tue Jul 31 10:17:44 2012] [notice] Apache/2.2.22 (Unix) DAV/2 mod_wsgi/3.3 Python/2.7.3 configured -- resuming normal operations

and no warn line.

Additional info:

This might or might not be a blocker for bug 833139.
Comment 1 Joe Orton 2012-11-22 08:16:04 EST
It's only a warning; fixed in current releases.

Note You need to log in before you can comment on or make changes to this bug.