Bug 844718 - clean up: remove "(an * next to a Red Hat repository indicates it is deployed in the RHUI)" from entitlement cert gen screen
clean up: remove "(an * next to a Red Hat repository indicates it is deployed...
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: wes hayutin
Martin Kočí
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 09:36 EDT by wes hayutin
Modified: 2012-08-24 09:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In the earlier versions of Red Hat update Infrastructure user interface, the entitlement certificate generation screen displayed a message stating that "* indicates the repositories deployed on RHUI". This update cleans up the user interface by removing this message as it is no longer applicable.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 07:55:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2012-07-31 09:36:46 EDT
Description of problem:

clean up: remove "(an * next to a Red Hat repository indicates it is deployed in the RHUI)" from entitlement cert gen screen

RHUI now displays a filtered list of repositories that a customer can create an entitlement certificate from.. an improvement over the 2.0.3 code for sure...

Just need to remove the legacy instructions..
Comment 1 wes hayutin 2012-07-31 09:51:53 EDT
[whayutin@whayutin-devel screens]$ git show a34f94f743e694861cfe2ef72d61f618f9357458
commit a34f94f743e694861cfe2ef72d61f618f9357458
Author: Wes Hayutin <whayutin@redhat.com>
Date:   Tue Jul 31 09:51:00 2012 -0400

    844718, remove obsolete instructions for selecting repos for entitlement cert

diff --git a/rhui-2.0/tools/src/rhui/tools/screens/client.py b/rhui-2.0/tools/src/rhui/tools/screens/client.py
index 935b5a2..eebaaba 100644
--- a/rhui-2.0/tools/src/rhui/tools/screens/client.py
+++ b/rhui-2.0/tools/src/rhui/tools/screens/client.py
@@ -110,7 +110,6 @@ class ClientScreen(Screen):
 
         # Prompt the user to select repos to include
         q =  'Select one or more repositories to include in the entitlement certificate:\n'
-        q += '(an * next to a Red Hat repository indicates it is deployed in the RHUI)\n'
         selected_section_indices = self.prompt.prompt_multiselect_sectioned_menu(q, sections, section_post_text='', interruptable=True)
         self.prompt.write(''
Comment 2 Martin Kočí 2012-08-06 08:55:18 EDT
checked against /root/RHEL-6.3-RHUI-2.1-20120801.0-Server-x86_64-DVD1.iso. Successfully reproduced on /root/RHEL-6.3-RHUI-2.1-20120705.0-Server-x86_64-DVD1.iso. 
See output:

rhui (client) => e

Select the CDS cluster that clients using this entitlement certificate will use to download content:

  1  - clsuter01
Enter value (1-1) or 'b' to abort: 1

Select one or more repositories to include in the entitlement certificate:

  Custom Repositories

  Red Hat Repositories
    -  1 : Red Hat Enterprise Linux 6 Server from RHUI (RPMs)
    -  2 : Red Hat Update Infrastructure 1.2 (RPMs)
    -  3 : Red Hat Update Infrastructure 2.0 (RPMs)

Enter value (1-3) to toggle selection, 'c' to confirm selections, or '?' for more commands:

Moving bug to VERIFIED.
Comment 3 Shikha 2012-08-16 04:47:19 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In the earlier versions of Red Hat update Infrastructure user interface, the entitlement certificate generation screen displayed a message stating that "* indicates the repositories deployed on RHUI". This update cleans up the user interface by removing this message as it is no longer applicable.
Comment 5 errata-xmlrpc 2012-08-24 07:55:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.