Bug 844727 - Guide Me: If you check port mirroring checkbox when creating new VM, it will show up with port mirroring checkbox unchecked when created
Guide Me: If you check port mirroring checkbox when creating new VM, it will ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alona Kaplan
GenadiC
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-31 10:14 EDT by GenadiC
Modified: 2016-02-10 14:52 EST (History)
7 users (show)

See Also:
Fixed In Version: si14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:00:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description GenadiC 2012-07-31 10:14:40 EDT
Description of problem:
Create the new VM and check the port mirroring checkbox. When that VM will be created the port mirroring checkbox will be still unchecked.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create new VM and check port mirroring checkbox
2.
3.
  
Actual results:
VM is created but Port mirroring is unchecked

Expected results:
Port mirroring should be checked

Additional info:
If performing editing to the existing VM, Port mirroring is checked as it should be, so the problem is only on the new VM
Comment 1 Itamar Heim 2012-07-31 12:34:05 EDT
I must be missing something, but port mirroting is vnic level, not vm level?
Comment 2 GenadiC 2012-08-01 00:36:20 EDT
You are right, but there are 2 options to check port mirroring option - 1) when editing existing NIC, 2) When creating the new VM and checking Port Mirroring check box when adding the new NIC.
So the problem is that in the second scenario after checking Port Mirroring check box, the VM will still be with this option unchecked.
The first case works fine.
Comment 3 lpeer 2012-08-01 02:37:40 EDT
(In reply to comment #1)
> I must be missing something, but port mirroting is vnic level, not vm level?

I think Genadi means that when using the Guid Me dialog for crating new nics we loose the port mirroring value.

Genadi - please confirm.
Comment 4 GenadiC 2012-08-01 04:08:09 EDT
(In reply to comment #3)
> (In reply to comment #1)
> > I must be missing something, but port mirroting is vnic level, not vm level?
> 
> I think Genadi means that when using the Guid Me dialog for crating new nics
> we loose the port mirroring value.
> 
> Genadi - please confirm.

Yes Livnat, you are right.
That's what I tried to explain in Comment #2
Comment 5 Alona Kaplan 2012-08-06 05:46:31 EDT
fixed in commit 680f92eb3fc83c28b2561de21281840b0a7a116d
Comment 6 GenadiC 2012-08-16 05:22:59 EDT
Verified in SI14

Note You need to log in before you can comment on or make changes to this bug.