Bug 844855 - libra_check site tests are taking longer than US2545
libra_check site tests are taking longer than US2545
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Test Suite (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 00:07 EDT by Dan McPherson
Modified: 2015-05-14 22:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 16:42:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan McPherson 2012-08-01 00:07:47 EDT
Actual results:

          -----------------------------------------------------------
                      Begin Output From Site Check Tests
          -----------------------------------------------------------

(in /root/li-test/site)
Loaded suite /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader
Started
...............................................................................................................................................................................................
Finished in 9.173332 seconds.

191 tests, 831 assertions, 0 failures, 0 errors
Loaded suite /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader
Started
......................................................................................................................................................................
Finished in 514.375028 seconds.

166 tests, 668 assertions, 0 failures, 0 errors
Aria is not available: (./test/integration/aria_test.rb:120) authentication error (1004)
Aria is not available: (./test/integration/plan_signup_flow_test.rb:84) authentication error (1004)
Loaded suite /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader
Started
.............................................
Finished in 137.366254 seconds.

45 tests, 205 assertions, 0 failures, 0 errors

          -----------------------------------------------------------
                       End Output From Site Check Tests
          -----------------------------------------------------------


Expected results:

- < 5 mins
- Some granularity on retries
Comment 1 Clayton Coleman 2012-08-01 15:39:19 EDT
Waiting for review.
Comment 2 Xiaoli Tian 2012-08-03 03:18:26 EDT
The following are the test result on libra_check 2830, most groups of site testing will consume less than 5 minutes,  not sure if you mean it should consume less than 5 minutes for all site check testing or just for each group.

Leave this bug for you to decide if it should be closed or assigned back since it's a test suite bug.
  
        -----------------------------------------------------------
                      Begin Output From Site Check Base Tests
Started
.................................................................................
Finished in 134.648635 seconds.

339 tests, 1333 assertions, 0 failures, 0 errors

                      Begin Output From Site Check Cartridges Tests
          -----------------------------------------------------------

Started
......
Finished in 189.027993 seconds.

6 tests, 49 assertions, 0 failures, 0 errors

          -----------------------------------------------------------
                       End Output From Site Check Cartridges Tests
          -----------------------------------------------------------
                     Begin Output From Site Check REST API Integration Tests
     
Started
.....................
Finished in 150.90883 seconds.

21 tests, 99 assertions, 0 failures, 0 errors

          -----------------------------------------------------------
                       End Output From Site Check REST API Integration Tests
                   Begin Output From Site Check Applications Tests
          -----------------------------------------------------------
.....................
Finished in 356.604411 seconds.

21 tests, 77 assertions, 0 failures, 0 errors

          -----------------------------------------------------------
                       End Output From Site Check Applications Tests

                     Begin Output From Site Check Miscellaneous 1 Tests
          -----------------------------------------------------------

(in /root/li-test/site)
Loaded suite /usr/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/rake_test_loader
Started
..........................
Finished in 241.34743 seconds.

26 tests, 194 assertions, 0 failures, 0 errors

          -----------------------------------------------------------
                       End Output From Site Check Miscellaneous 1 Tests
          -----------------------------------------------------------
Comment 3 Clayton Coleman 2012-08-03 12:23:40 EDT
Dan and I agreed that if each individual test was close to 5 minutes we'd call it success and move on.  Thanks for reviewing though :)

Clayton signing off on this

Note You need to log in before you can comment on or make changes to this bug.