Bug 84488 - dynamic and static IP on two different cards won't work
dynamic and static IP on two different cards won't work
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-17 18:05 EST by Anthony Frum
Modified: 2014-03-16 22:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 16:37:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Frum 2003-02-17 18:05:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I have a Linksys 10/100 NIC (eth0) and a Netgear GA302T gigabit NIC (eth1)
installed and working on my RH8.0 Linux machine.  I have eth0 connected directly
to my cable modem and set for obtaining IP automatically through DHCP.  I have
eth1 set to a static, private IP and connected to my network's switch.

Both of these ethernet connections work.  I can browse the internet and use all
network resources.  The problem I have is that I can't do them both at the same
time.  If I activate both NICs at the same time with this configuration, the
computer slows down to an unbelievable crawl (30-60 seconds to open a shell). 
This is not a hardware conflict, I don't believe, though, because if I set eth0
to any static IP (which kills my internet access) they can both activate and
work in harmony.  I am absolutely positive that the issue is with eth0 running
dynamic IP and eth1 running static at the same time.  Any change to that setup
keeps the system from slowing down.

There is one quirk I've noticed about when this issue comes about.  If I don't
have the NICs initialize on startup of the computer, and then I activate them
after I boot, and then log out and log back in, I get the following error message:

Could not look up internet address for x1-6-00-04-5a-68-f2-6b.  This will
prevent GNOME from operating correctly.  It may be possible to correct the
problem by adding x1-6-00-04-5a-68-f2-6b to the file /etc/hosts.

The MAC address of my eth0 card is 00-04-5a-68-f2-6b.  Obviously this is not an
IP address and therefore does not belong in the /etc/hosts file.  I did not
bother trying to add it.  The connection between the error message and the MAC
address might be valuable information to someone smarter than me, but I wasn't
able to come up with an answer.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set up eth0 to obtain an IP address automatically using DHCP and eth1 to have
a static IP.
2.Plug eth0 into a cable modem. eth1 does not need to be connected to any
network device.
3.Activate both NICs
    

Actual Results:  The computer takes 30 seconds or more to respond to nearly any
request to open a program.  Shells, network configuration utility, and text
editor are all that I remember trying to open.  Sometimes they just won't open
at all.

Expected Results:  The two NICs should have worked properly on their respective
networks, and the computer should continue operating as normal

Additional info:

For what it's worth my prompt in my bash shell changed from:

[root@localhost root]#

to:

[root@x1-6-04-5a-68-f2-6b root]#
Comment 1 Anthony Frum 2003-02-17 18:09:12 EST
I forgot to mention that on the various linux forums that I read, I found two
other people with this issue.  One was able to resolve it using PPPoE over DSL.
 This was just to avoid obtaining an IP through DHCP.  The other person and I
have yet to find a way around this issue as we both use cable (no PPPoE).
Comment 2 Harald Hoyer 2003-02-18 05:21:28 EST
this is more an initscripts / linux network configuration / general network
setup problem
Comment 3 Bill Nottingham 2003-02-18 11:50:01 EST
What does your /etc/sysconfig/network and /etc/sysconfig/network-scripts/ifcfg-*
look like? It sounds like you may have misconfigured name service.
Comment 4 Anthony Frum 2003-02-19 00:44:35 EST
/etc/sysconfig/network:

NETWORKING = yes
HOSTNAME=localhost.localdomain


/etc/sysconfig/network-scripts/ifcfg-eth0:

DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
USERCTL=no
PEERDNS=no
TYPE=Ethernet
NETWORK=231.52.0.0
BROADCAST=231.52.255.255


/etc/sysconfig/network-scripts/ifcfg-eth1:

# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
USERCTL=no
PEERDNS=no
GATEWAY=192.168.1.1
TYPE=Ethernet
DEVICE=eth1
BOOTPROTO=none
NETMASK=255.255.255.0
ONBOOT=yes
IPADDR=192.168.1.2
NETWORK=192.168.1.0
BROADCAST=192.168.1.255


/etc/sysconfig/network-scripts/ifcfg-lo:

# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
NAME=loopback


Keep in mind that I had to type these by hand, so if there is some small error, 
it could be a typo.  Thank you so much for your help.  I sincerely appreciate 
it.
Comment 5 Bill Nottingham 2003-02-19 01:29:11 EST
What does your /etc/resolv.conf look like? You may want to set PEERDNS=yes
for your DHCP address.
Comment 6 Anthony Frum 2003-02-20 01:22:59 EST
Here is my /etc/resolv.conf:

; generated by /sbin/dhclient-script
search attbi.com
nameserver 204.127.202.4
nameserver 216.148.227.68

I didn't get a chance to try PEERDNS=yes.  Given the above information, would 
you still recommend that I try that?  Or do you have a different solution?  
Again, thank you very much for your help.
Comment 7 Anthony Frum 2003-02-24 12:03:51 EST
I tried setting PEERDNS=yes in my eth0 (dhcp).  I got the same result.  Do you
need any other information or have any other suggestions?  :(
Comment 8 Anthony Frum 2003-03-03 01:13:51 EST
I still can't find a solution to this issue.  Can you offer any more 
suggestions?  I'm totally lost.
Comment 9 Bill Nottingham 2003-03-03 16:02:27 EST
What is your hostname set to? What does your routing table look like when they
are both up?
Comment 10 Anthony Frum 2003-03-03 19:10:55 EST
My hostname is localhost, I believe.  That's what my prompt shows up as, 
anyway.  As far as the routing table goes, I don't know what to tell you.  I'm 
a newbie to Linux.  I can't even bring up a terminal when I have both network 
cards running.  I haven't made any changes to the routing table knowingly since 
I installed RH.  I had planned to look into learning this stuff after I was 
able to get the two network cards running at the same time.  Until then it's a 
moot point.  ;)

Thanks for the help.
Comment 11 Bill Nottingham 2003-03-03 22:51:12 EST
If you can't bring up a terminal with both cards running...

Did you bring up the cards while in a GUI? If so, it's possible your hostname
changed. This will prevent the opening of new windows.
Comment 12 Anthony Frum 2003-03-04 13:27:09 EST
Yes, I am using GNOME when I "activate" the cards.  The computer will not boot
if I have them activate on startup, so I have to do it after the computer has
booted.  I do not know how to do this from a shell, so I just use the network
configuration tool in GNOME.  Should I do something else?

And I'm not sure what you mean about the hostname changing, but when I log in
with both cards activated (boot, log in, activate, log out, log back in), it
says Welcome to x1-00...(see above for exact phrase) instead of Welcome to
localhost.localdomain.  Is this what you're referring to?
Comment 13 Bill Nottingham 2003-03-04 14:31:49 EST
Yes, that's what I mean by the hostname changing. If the hostname changes out
from under X, you won't be able to start new apps without restarting X.
Comment 14 Anthony Frum 2003-03-04 20:43:20 EST
Okay.  When I do this, what do I need to do to get the information you need?  
Help me help you help me, hehe.
Comment 15 Anthony Frum 2003-03-07 18:52:01 EST
I really don't want to be belligerent, but could you tell me what I should do
next?  I've exhausted my limited knowledge on the subject and need your advice.
 If you need information, tell me how to get it and I'll make sure you have it.
Comment 16 Bill Nottingham 2003-03-10 16:52:49 EST
In what way will it not boot if you have them both activated on startup?
Is it just slow?
Comment 17 Anthony Frum 2003-04-17 15:58:40 EDT
I am sorry for how long it has been since my last post.  I had to tear down my
Linux server and make it a Windows box for a while, but it is back in full
swing... and with the same problem.

It goes through the services at boot time (where each shows an "OK" or "FAIL"),
and pauses for a long time on one and totally stops on the other.  Would you
like to know which ones, or is that irrelevant?

Again, thank you for the effort on this issue.  It is keeping me from doing a
great deal with my Linux server.
Comment 18 Bill Nottingham 2003-04-17 16:02:21 EDT
No, knowing as close as possible the exact error messages will help.
Comment 19 Anthony Frum 2003-04-17 18:45:03 EDT
Okay, I tried booting up again with the cable modem plugged into eth0, eth0 set
up for DHCP and to activate on startup.  Everything went fine for a sec.. eth0
came up and so did eth1 without a hitch.  However, the very next service was
System Logger, and it took a good 60 seconds to start.  The next snag was at
sendmail and it took about as long to start.  Then when I tried to log in and
start GNOME, I got the following error message again (typed, so typos are my bad):

Could not look up internet address for x1-6-00-04-5a-68-f2-6b.  This will
prevent GNOME from operating correctly.  It may be possible to correct the
problem by adding x1-6-00-04-5a-68-f2-6b to the file /etc/hosts.

So, is the problem that my cable modem service is somehow dictating the hostname
that GNOME is trying to connect to?  And if so, how do I fix it?
Comment 20 Bill Nottingham 2003-04-17 19:02:09 EDT
Hm, you might try booting in runlevel 3 to avoid going into gnome. But yes, it
looks like something strange is happening with your cable modem. What does
'route -n' say after both devices are up?
Comment 21 Drew Kroft 2004-05-07 14:24:54 EDT
i began getting this similar behavior this last week.
single network card, 
boots up, 
eth0 OK, 
syslog - 60-90 second pause OK
ntpd - 60-90 second pause - FAILED
gnome comes up, 
can ping other machines on the subnet and that router,
but no dns resolution,
no connection past router.

i just noticed dhclient running; never noticed that before.

might this be related to ACPI & udev?
Comment 22 Atomizer 2004-05-12 16:48:26 EDT
I have the same configuration than you, but working (on FC1 and RH 7.2) ;)
 - try to use a defroute value
 - be carefull with gateway unreacheable ( or which doesn't exist)

Some configuration files, with unused field (note that i only
understand first of them...)
I hope this will help you

RH 7.2
/etc/sysconfig/network:
NETWORKING=yes
HOSTNAME="Station.Marcilly.com"
FORWARD_IPV4="no"
GATEWAY=""
GATEWAYDEV=""

/etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE="eth0"
BOOTPROTO="none"
BROADCAST=192.168.1.255
IPADDR="192.168.1.27"
NETMASK="255.255.255.0"
NETWORK=192.168.1.0
ONBOOT="yes"
TYPE=Ethernet
USERCTL=no
PEERDNS=no
IPXNETNUM_802_2=""
IPXPRIMARY_802_2="no"
IPXACTIVE_802_2="no"
IPXNETNUM_802_3=""
IPXPRIMARY_802_3="no"
IPXACTIVE_802_3="no"
IPXNETNUM_ETHERII=""
IPXPRIMARY_ETHERII="no"
IPXACTIVE_ETHERII="no"
IPXNETNUM_SNAP=""
IPXPRIMARY_SNAP="no"
IPXACTIVE_SNAP="no"


/etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE="eth1"
BOOTPROTO="dhcp"
#BROADCAST=10.255.255.255
#IPADDR="10.0.0.27"
#NETMASK="255.0.0.0"
#NETWORK=10.0.0.0
ONBOOT="yes"
TYPE=Ethernet
DEFROUTE="yes"
USERCTL=no
PEERDNS=yes
IPXNETNUM_802_2=""
IPXPRIMARY_802_2="no"
IPXACTIVE_802_2="no"
IPXNETNUM_802_3=""
IPXPRIMARY_802_3="no"
IPXACTIVE_802_3="no"
IPXNETNUM_ETHERII=""
IPXPRIMARY_ETHERII="no"
IPXACTIVE_ETHERII="no"
IPXNETNUM_SNAP=""
IPXPRIMARY_SNAP="no"
IPXACTIVE_SNAP="no"


/etc/dhcpd.conf     ( RH 7.2 with dhcp-2.0pl5-8.i386.rpm)
subnet 192.168.1.0 netmask 255.255.255.0 {
        option routers                  192.168.1.27;
        option subnet-mask              255.255.255.0;

        option domain-name              "free.fr";
#       option domain-name-servers      193.252.19.3, 193.252.19.4;
        option domain-name-servers      212.27.39.2, 212.27.39.134;

        option time-offset              -18000; # Eastern Standard Time

        range dynamic-bootp 192.168.1.101 192.168.1.200;
        default-lease-time 21600;
        max-lease-time 43200;
}
subnet 82.226.67.0 netmask 255.255.255.0 {
    not authoritative;
    deny unknown-clients;
    deny bootp;
    deny booting;
}


/etc/dhcpd.conf     ( FC1 with dhcp-3.0pl2-6.16.i386.rpm, )
Only the first two line is important, other ones are for a test

ddns-update-style interim;
ignore client-updates;
subnet 192.168.10.0 netmask 255.255.255.0 {
        option routers                  192.168.10.25;
        option subnet-mask              255.255.255.0;

        option domain-name              "marcilly.com";
        option domain-name-servers      212.27.39.2, 212.27.39.134;

        option time-offset              -18000; # Eastern Standard Time

        range dynamic-bootp 192.168.10.101 192.168.10.200;
        default-lease-time 21600;
        max-lease-time 43200;
}
subnet 192.168.1.0 netmask 255.255.255.0 {
    not authoritative;
    deny unknown-clients;
    deny bootp;
    deny booting;
}


Atomizer
Comment 23 Bill Nottingham 2005-09-29 16:37:06 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.