Bug 844929 - SELinux is preventing /usr/bin/hostname from 'execute' accesses on the file /usr/bin/hostname.
SELinux is preventing /usr/bin/hostname from 'execute' accesses on the file /...
Status: CLOSED DUPLICATE of bug 844923
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4cdcaf01fcd922634978b8be8c6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 05:41 EDT by mamii
Modified: 2012-08-01 07:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 07:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mamii 2012-08-01 05:41:42 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.x86_64
time:           Wed 01 Aug 2012 10:41:25 AM CET

description:
:SELinux is preventing /usr/bin/hostname from 'execute' accesses on the file /usr/bin/hostname.
:
:*****  Plugin leaks (86.2 confidence) suggests  ******************************
:
:If you want to ignore hostname trying to execute access the hostname file, because you believe it should not need this access.
:Then you should report this as a bug.  
:You can generate a local policy module to dontaudit this access.
:Do
:# grep /usr/bin/hostname /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If you believe that hostname should be allowed execute access on the hostname file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep hostname /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:hostname_exec_t:s0
:Target Objects                /usr/bin/hostname [ file ]
:Source                        hostname
:Source Path                   /usr/bin/hostname
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           hostname-3.10-1.fc17.x86_64
:Target RPM Packages           hostname-3.10-1.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-2.fc17.x86_64 #1 SMP
:                              Mon Jul 30 14:48:59 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 01 Aug 2012 10:39:43 AM CET
:Last Seen                     Wed 01 Aug 2012 10:39:43 AM CET
:Local ID                      a078c622-ede8-4a1e-bd31-1fbd26218822
:
:Raw Audit Messages
:type=AVC msg=audit(1343813983.14:183): avc:  denied  { execute } for  pid=6130 comm="bash" name="hostname" dev="dm-2" ino=1211677 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hostname_exec_t:s0 tclass=file
:
:
:type=AVC msg=audit(1343813983.14:183): avc:  denied  { open } for  pid=6130 comm="bash" path="/usr/bin/hostname" dev="dm-2" ino=1211677 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hostname_exec_t:s0 tclass=file
:
:
:type=AVC msg=audit(1343813983.14:183): avc:  denied  { execute_no_trans } for  pid=6130 comm="bash" path="/usr/bin/hostname" dev="dm-2" ino=1211677 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hostname_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1343813983.14:183): arch=x86_64 syscall=execve success=yes exit=0 a0=165b2a0 a1=165c040 a2=165d440 a3=10 items=0 ppid=6129 pid=6130 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=hostname exe=/usr/bin/hostname subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: hostname,system_dbusd_t,hostname_exec_t,file,execute
:
:audit2allow
:
:#============= system_dbusd_t ==============
:allow system_dbusd_t hostname_exec_t:file { execute open execute_no_trans };
:
:audit2allow -R
:
:#============= system_dbusd_t ==============
:allow system_dbusd_t hostname_exec_t:file { execute open execute_no_trans };
:
Comment 1 Miroslav Grepl 2012-08-01 07:05:19 EDT

*** This bug has been marked as a duplicate of bug 844923 ***

Note You need to log in before you can comment on or make changes to this bug.