Bug 844932 - SELinux is preventing /usr/bin/su from 'write' accesses on the key .
SELinux is preventing /usr/bin/su from 'write' accesses on the key .
Status: CLOSED DUPLICATE of bug 844923
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ce44cce1f6733df3184d355c0a1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 05:42 EDT by mamii
Modified: 2012-08-01 07:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 07:05:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mamii 2012-08-01 05:42:54 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.x86_64
time:           Wed 01 Aug 2012 10:42:35 AM CET

description:
:SELinux is preventing /usr/bin/su from 'write' accesses on the key .
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that su should be allowed write access on the  key by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep su /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
:Target Objects                 [ key ]
:Source                        su
:Source Path                   /usr/bin/su
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           coreutils-8.15-7.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-2.fc17.x86_64 #1 SMP
:                              Mon Jul 30 14:48:59 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Wed 01 Aug 2012 10:39:42 AM CET
:Last Seen                     Wed 01 Aug 2012 10:40:17 AM CET
:Local ID                      7ee4d022-e82c-4120-8ee1-92a020d56973
:
:Raw Audit Messages
:type=AVC msg=audit(1343814017.204:186): avc:  denied  { write } for  pid=6125 comm="su" scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tclass=key
:
:
:type=SYSCALL msg=audit(1343814017.204:186): arch=x86_64 syscall=keyctl success=yes exit=0 a0=3 a1=3a8e2c5c a2=0 a3=0 items=0 ppid=5769 pid=6125 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=su exe=/usr/bin/su subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: su,system_dbusd_t,system_dbusd_t,key,write
:
:audit2allow
:
:#============= system_dbusd_t ==============
:allow system_dbusd_t self:key write;
:
:audit2allow -R
:
:#============= system_dbusd_t ==============
:allow system_dbusd_t self:key write;
:
Comment 1 Miroslav Grepl 2012-08-01 07:05:36 EDT

*** This bug has been marked as a duplicate of bug 844923 ***

Note You need to log in before you can comment on or make changes to this bug.