Bug 844933 - SELinux is preventing /usr/bin/su from 'open' accesses on the file /usr/bin/su.
SELinux is preventing /usr/bin/su from 'open' accesses on the file /usr/bin/su.
Status: CLOSED DUPLICATE of bug 844923
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5649e84bc072dbc20b64f20c705...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 05:43 EDT by mamii
Modified: 2012-08-01 07:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 07:05:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mamii 2012-08-01 05:43:16 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.x86_64
time:           Wed 01 Aug 2012 10:42:59 AM CET

description:
:SELinux is preventing /usr/bin/su from 'open' accesses on the file /usr/bin/su.
:
:*****  Plugin leaks (86.2 confidence) suggests  ******************************
:
:If you want to ignore su trying to open access the su file, because you believe it should not need this access.
:Then you should report this as a bug.  
:You can generate a local policy module to dontaudit this access.
:Do
:# grep /usr/bin/su /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If you believe that su should be allowed open access on the su file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep su /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:su_exec_t:s0
:Target Objects                /usr/bin/su [ file ]
:Source                        su
:Source Path                   /usr/bin/su
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           coreutils-8.15-7.fc17.x86_64
:Target RPM Packages           coreutils-8.15-7.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-2.fc17.x86_64 #1 SMP
:                              Mon Jul 30 14:48:59 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 01 Aug 2012 10:39:42 AM CET
:Last Seen                     Wed 01 Aug 2012 10:39:42 AM CET
:Local ID                      14f564f0-8c69-47fb-9b10-1df9c7731b78
:
:Raw Audit Messages
:type=AVC msg=audit(1343813982.948:175): avc:  denied  { open } for  pid=6125 comm="sh" path="/usr/bin/su" dev="dm-2" ino=1178791 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:su_exec_t:s0 tclass=file
:
:
:type=AVC msg=audit(1343813982.948:175): avc:  denied  { execute_no_trans } for  pid=6125 comm="sh" path="/usr/bin/su" dev="dm-2" ino=1178791 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:su_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1343813982.948:175): arch=x86_64 syscall=execve success=yes exit=0 a0=15c48f0 a1=15c5030 a2=15c3ac0 a3=28 items=0 ppid=5769 pid=6125 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=su exe=/usr/bin/su subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: su,system_dbusd_t,su_exec_t,file,open
:
:audit2allow
:
:#============= system_dbusd_t ==============
:allow system_dbusd_t su_exec_t:file { open execute_no_trans };
:
:audit2allow -R
:
:#============= system_dbusd_t ==============
:allow system_dbusd_t su_exec_t:file { open execute_no_trans };
:
Comment 1 Miroslav Grepl 2012-08-01 07:05:49 EDT

*** This bug has been marked as a duplicate of bug 844923 ***

Note You need to log in before you can comment on or make changes to this bug.