Bug 845041 - UI - Exact Errata search in content search does not return result.
UI - Exact Errata search in content search does not return result.
Status: CLOSED UPSTREAM
Product: Katello
Classification: Community
Component: WebUI (Show other bugs)
1.X
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Hayk Hovsepyan
:
: 854594 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 11:03 EDT by Hayk Hovsepyan
Modified: 2012-10-29 10:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-29 10:27:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2012-08-01 11:03:25 EDT
Description of problem:
If you search exact errata in content search by putting for example "RHBA-2010:0836" in input bod and click Go, it does not return that errata and list of results is empty on right part. Which is bug.
Also, try to search by wrong errata, for example "RHBA-9", it will return a huge list of errata.

Version-Release number of selected component (if applicable):
Katello Version: 1.1.0-1.git.10.b1a330e.el6_3

How reproducible:
allways

Steps to Reproduce:
1. Import some manifest which repos contain errata. For example standart ACME_Corporation manifest with RHEL6.

2. Activate the repo " Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server" and sync it.

3. From UI go to Content > Content Search. Select "Errata" in Content dropdown to search. Input some exact errata in input box (for example "RHBA-2010:0836") and click "Go" button. It does not return errata, which is bug.

4. Try to search by providing wrong errata, like "RHBA-9". And it will return a lot of errata, which is bug as well.

  
Actual results:
No Errata is loaded on the right part and search result list is empty.

Expected results:
Only that exact errata should be loaded according to requirements.
Comment 1 Pavel Pokorny 2012-09-06 03:34:21 EDT
*** Bug 854594 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Suchý 2012-10-10 17:04:44 EDT
taking
Comment 3 Miroslav Suchý 2012-10-16 10:41:03 EDT
https://github.com/Katello/katello/pull/598

Pajk 	845041 - UI - Exact Errata search in content search does not return r… … 	5bc674e
Comment 4 Lukas Zapletal 2012-10-29 10:27:49 EDT
Part of Katello 1.1 release

Note You need to log in before you can comment on or make changes to this bug.