This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 845077 - Dell XPS 13: Backlight Brightness Controls Not Working
Dell XPS 13: Backlight Brightness Controls Not Working
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 12:43 EDT by Lorenzo Villani
Modified: 2013-11-08 05:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 17:48:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
[PATCH 1/4] drm/i915: pnv has a backlight polarity control bit, too (1.11 KB, patch)
2012-08-01 12:47 EDT, Lorenzo Villani
no flags Details | Diff
[PATCH 2/4] drm/i915: clear up backlight #define confusion on gen4+ (5.35 KB, patch)
2012-08-01 12:50 EDT, Lorenzo Villani
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 954661 None None None 2012-08-01 12:43:15 EDT

  None (edit)
Description Lorenzo Villani 2012-08-01 12:43:15 EDT
Description of problem:
Brightness controls on Dell XPS 13 don't work.

There's a patch set available at http://lists.freedesktop.org/archives/intel-gfx/2012-June/018030.html which solves the issue (tested with a locally rebuilt kernel RPM which includes said stack of patches).


Version-Release number of selected component (if applicable):
3.4.6-1


How reproducible:
Always


Steps to Reproduce:
1. Press Fn+F4 or Fn+F5 to decrease/increase the panel brightness;


Actual results:
Panel brightness doesn't change (although Gnome shows the display brightness popup).


Expected results:
Panel brightness should increase and decrease as I press the buttons.


Additional info:
It is possible to work-around the problem by creating an acpid event file like the following:

https://raw.github.com/lvillani/post-install/078d47358be70d23d4edc93eea527a4898175e50/files/acpi/intel_workaround
Comment 1 Lorenzo Villani 2012-08-01 12:47:57 EDT
Created attachment 601782 [details]
[PATCH 1/4] drm/i915: pnv has a backlight polarity control bit, too
Comment 2 Lorenzo Villani 2012-08-01 12:50:12 EDT
Created attachment 601783 [details]
[PATCH 2/4] drm/i915: clear up backlight #define	confusion on gen4+
Comment 3 Lorenzo Villani 2012-08-01 13:35:50 EDT
Oh wait... looks like these patches were merged in 3.5.0. I'm rebuilding my customized kernel RPMs (which include other patches for my Dell XPS 13) in order to test it.
Comment 4 Lorenzo Villani 2012-08-03 10:02:55 EDT
I'm now running kernel-3.6.0-0.rc0.git9.3.fc18.x86_64 and the issue seems to be fixed.

Can the patch-set be backported to F-16 and F-17 kernels?
Comment 5 Justin M. Forbes 2012-08-17 17:48:48 EDT
The 3.5 kernels are coming to F16 soon, we have one major issue that F17 users are experiencing that we need to get fixed first.
Comment 6 Rolle 2013-11-08 05:41:07 EST
With kernel 3.10 and 3.11 (actually until fedora kernel 3.11.7) it doesn't work for anymore. See Bug Report 1028383 and Bug Report 995782.
Comment 7 Rolle 2013-11-08 05:41:42 EST
Comment 6 was tried with Fedora 20 alpha

Note You need to log in before you can comment on or make changes to this bug.