Bug 845090 - Default KDE browser is buggy and provides a terrible first user experience.
Default KDE browser is buggy and provides a terrible first user experience.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kde-baseapps (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 14:13 EDT by Torrie Fischer
Modified: 2012-08-01 15:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 14:34:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 304392 None None None 2012-08-01 14:54:13 EDT

  None (edit)
Description Torrie Fischer 2012-08-01 14:13:48 EDT
Description of problem:

Girlfriend installed a copy of Fedora 17 with the KDE desktop. Tried to install chrome so she could have her google sync settings and it was her favorite browser, but the webpage's javascript wasn't correctly handled by KHTML, leaving her without the download popup and a spinner image saying that something was loading.

The default browser should Just Work, and not cause a trainwreck of a user experience.


Version-Release number of selected component (if applicable):

Fedora 17, Konqueror 4.8.3.


How reproducible:

100%


Steps to Reproduce:
1. Visit http://google.com/chrome
2. Try to download the 64 bit fedora RPM.
  
Actual results:

Frustration and exclamations that linux clearly isn't ready for the desktop, leading to the expert fedora boyfriend installing firefox and trying to convince her that her first real experience with linux doesn't reflect the behavior of the rest of the desktop.


Expected results:

Chrome gets installed.

Additional info:

Installing firefox fixes this bug. Further experiments show that facebook does not work 100% in konqueror, along with our bank's website and "the one facebook game that keeps me using windows since flash doesn't work" (it works fine on fedora now that she uses chrome).
Comment 1 Kevin Kofler 2012-08-01 14:34:38 EDT
Bugzilla is not an appropriate venue for this kind of change requests.
Comment 2 Kevin Kofler 2012-08-01 14:35:42 EDT
And any concrete issues with Konqueror should be reported directly to bugs.kde.org.
Comment 3 Torrie Fischer 2012-08-01 14:39:20 EDT
Where exactly do I send change requests then?

I assume then that since this isn't a bug, it is expected behavior to be unable to download chrome on a fresh install of Fedora 17?
Comment 4 Kevin Kofler 2012-08-01 14:59:49 EDT
> Where exactly do I send change requests then?

The default applications are discussed in KDE SIG meetings.

That said, the default browser topic has been rehashed many times and Konqueror was the decision for several practical reasons (it's dragged in by the KDE workspace, it's small, it's a KDE app and it's upstream KDE's default browser), so I'm not convinced rehashing this issue is productive.

Please keep in mind that the choice of defaults is a highly subjective matter and you cannot make everyone happy. (You have to sometimes make unpopular decisions in Phonon as well. And look at how you have 2 different backends because people cannot agree on which is the "best".)

> I assume then that since this isn't a bug, it is expected behavior to be unable > to download chrome on a fresh install of Fedora 17?

That's a KHTML bug (or missing feature, depending on what exactly the JavaScript on that site is trying to do), I'm sure the upstream KHTML developers would be happy to hear about it (and that way there's some chance the issue can be fixed in F17 updates, whereas default applications for F17 CANNOT be changed anymore, the defaults discussion would be for F18 at the earliest).
Comment 5 Kevin Kofler 2012-08-01 15:01:00 EDT
Thanks for having filed the upstream bug report (kde#304392).

Note You need to log in before you can comment on or make changes to this bug.