Bug 845094 - login denied read/open/getattr access to /run/nologin
login denied read/open/getattr access to /run/nologin
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 14:38 EDT by Jerry James
Modified: 2012-08-03 07:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-03 07:57:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2012-08-01 14:38:00 EDT
Description of problem:
I am currently booting a Rawhide VM with enforcing=0 due to the systemd problems noted on fedora-devel and in bug 835867.  When logging into a TTY (because X won't start due to another Rawhide problem), I get this:

[ 3296.521301] type=1400 audit(1343845537.910:3): avc:  denied  { read } for  pid=5637 comm="login" name="nologin" dev="tmpfs" ino=11127 scontext=system_u:system_r:local_login_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_logind_var_run_t:s0 tclass=file
[ 3296.521639] type=1400 audit(1343845537.910:4): avc:  denied  { open } for  pid=5637 comm="login" path="/run/nologin" dev="tmpfs" ino=11127 scontext=system_u:system_r:local_login_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_logind_var_run_t:s0 tclass=file
[ 3296.522284] type=1400 audit(1343845537.911:5): avc:  denied  { getattr } for  pid=5637 comm="login" path="/run/nologin" dev="tmpfs" ino=11127 scontext=system_u:system_r:local_login_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_logind_var_run_t:s0 tclass=file

Version-Release number of selected component (if applicable):
selinux-policy-3.11.0-15.fc18.noarch
selinux-policy-targeted-3.11.0-15.fc18.noarch

How reproducible:
Always

Steps to Reproduce:
1. Boot a Rawhide machine (with enforcing=0 currently, else it won't boot)
2. Login on a TTY
  
Actual results:
The AVC messages above are printed on the TTY.  I don't know if this would prevent a successful login if in enforcing mode, since I can't currently boot successfully in enforcing mode.

Expected results:
No AVC messages.

Additional info:
Comment 1 Daniel Walsh 2012-08-03 07:57:33 EDT
Fixed in selinux-policy-3.11.1-1.fc18

Note You need to log in before you can comment on or make changes to this bug.