Bug 845153 - [Origin]The file 'cqpid.so' conflicts between attempted install of ruby-qpid-qmf and rubygem-qpid when build livecd
[Origin]The file 'cqpid.so' conflicts between attempted install of ruby-qpid-...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Kubernetes (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 22:24 EDT by xjia
Modified: 2015-05-14 22:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 16:42:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xjia 2012-08-01 22:24:06 EDT
Description of problem:
When build livced,some error was happpned.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.git clone https://github.com/openshift/crankcase.git
2.cd crankcase/build
3.rake build_setup without any error
4.rake build without any error
5.rake livecd

Actual results:
Transcation couldn't start:
file /usr/lib64/ruby/site_ruby/1.8/x86_64-linux/cqpid.so conflicts between attempted installs of ruby-qpid-qmf-0.16-2.fc16.x86_64 and rubygem-pid-0.16.0-12.fc16.1.x86_64

Expected results:
No such error.

Additional info:
I modify the file "crankcase/build/openshift-origin-broker/kickstart/openshift-origin-remix.ks", add "rubygem-qpid" in the "updates" exclude list.

repo --name=updates --mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$releasever&arch=$basearch --exclude=ruby,ruby-devel,ruby-irb,ruby-libs,ruby-rdoc,ruby-ri,ruby-static,ruby-tcltk,rubygem-qpid
Comment 1 Krishna Raman 2012-08-02 10:52:39 EDT
Caused by updated package in Fedora.
Fixed by https://github.com/openshift/crankcase/pull/312
Comment 2 xjia 2012-08-03 01:59:13 EDT
Pass verification.

Note You need to log in before you can comment on or make changes to this bug.