Bug 845188 - No error message when sign up with a registered email address on INT.
No error message when sign up with a registered email address on INT.
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 03:29 EDT by Mengjiao Gao
Modified: 2015-05-14 21:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-02 12:44:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mengjiao Gao 2012-08-02 03:29:04 EDT
Description of problem:
    After I registered my account with email address mgao+int01@redhat.com.I clicked the confirm url ,and have used it to create my apps. 
    Then I tried to sign up a new account with the same address(mgao+int01@redhat.com), but get no a successful register page with no error message.

Version-Release number of selected component (if applicable):

int
How reproducible:
always

Steps to Reproduce:
1.Sign up an account on INT, confirm it, and use it do some operations.
2.Go to sign up page, input the same email address.
3.
  
Actual results:
It returns a  page said registered successful.

Expected results:
User should get some error message said that the email have been registered.

Additional info:
Comment 1 Mengjiao Gao 2012-08-02 03:34:15 EDT
Sorry to make a mistake when discribe the problem. The last sentence of the  description should be :"Then I tried to sign up a new account with the same address(mgao+int01@redhat.com), but get a successful register page with no error message."
Comment 2 Clayton Coleman 2012-08-02 12:44:08 EDT
This is a security issue.  We do not expose whether a user already has an email account by design so that malicious parties can't detect whether the user has an account already.  So this is fixing a problem that was occurring.

Note You need to log in before you can comment on or make changes to this bug.