Bug 845237 - trying to do a yum update and it spews it guts up
trying to do a yum update and it spews it guts up
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 08:04 EDT by Joseph Fraser
Modified: 2015-02-17 09:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 09:22:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Fraser 2012-08-02 08:04:19 EDT
Description of problem:

ERROR with transaction check vs depsolve:

Version-Release number of selected component (if applicable):


How reproducible:
upgrade from fedora 15 to 17 (15,16,17)

Steps to Reproduce:
1.yum update
2. yum -y install dhclient
3.
  
Actual results:

Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package dhclient.i686 12:4.2.4-0.4.rc1.fc17 will be updated
---> Package dhclient.i686 12:4.2.4-9.P1.fc17 will be an update
--> Processing Dependency: dhcp-libs(x86-32) = 12:4.2.4-9.P1.fc17 for package: 12:dhclient-4.2.4-9.P1.fc17.i686
--> Processing Dependency: dhcp-common = 12:4.2.4-9.P1.fc17 for package: 12:dhclient-4.2.4-9.P1.fc17.i686
--> Running transaction check
---> Package dhcp-common.i686 12:4.2.4-0.4.rc1.fc17 will be updated
---> Package dhcp-common.i686 12:4.2.4-9.P1.fc17 will be an update
---> Package dhcp-libs.i686 12:4.2.4-0.4.rc1.fc17 will be updated
---> Package dhcp-libs.i686 12:4.2.4-9.P1.fc17 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch        Version                    Repository      Size
================================================================================
Updating:
 dhclient           i686        12:4.2.4-9.P1.fc17         updates        262 k
Updating for dependencies:
 dhcp-common        i686        12:4.2.4-9.P1.fc17         updates        163 k
 dhcp-libs          i686        12:4.2.4-9.P1.fc17         updates        130 k

Transaction Summary
================================================================================
Upgrade  1 Package (+2 Dependent packages)

Total download size: 555 k
Downloading Packages:
Setting up and reading Presto delta metadata
--------------------------------------------------------------------------------
Total                                           317 kB/s | 555 kB     00:01     
Running Transaction Check
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
ERROR with transaction check vs depsolve:
dhcp-common = 12:4.2.3-11.P2.fc16 is needed by (installed) dhcp-12:4.2.3-11.P2.fc16.i686
dhcp-libs(x86-32) = 12:4.2.3-11.P2.fc16 is needed by (installed) dhcp-12:4.2.3-11.P2.fc16.i686
** Found 91 pre-existing rpmdb problem(s), 'yum check' output follows:
ace-0.0.7-3.fc12.noarch has missing requires of ruby(abi) = ('0', '1.8', None)
ace-php-0.0.7-3.fc12.noarch has missing requires of ruby(abi) = ('0', '1.8', None)
compiz-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.i686 has missing requires of libboost_serialization-mt.so.1.47.0
compiz-gtk-0.9.5.92.1-0.2.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc16.i686 has missing requires of libboost_serialization-mt.so.1.47.0
compiz-plugins-main-0.9.5.92-1.fc16.i686 has missing requires of libboost_serialization-mt.so.1.47.0
12:dhcp-4.2.3-11.P2.fc16.i686 has missing requires of dhcp-common = ('12', '4.2.3', '11.P2.fc16')
12:dhcp-4.2.3-11.P2.fc16.i686 has missing requires of dhcp-libs(x86-32) = ('12', '4.2.3', '11.P2.fc16')
12:dhcp-4.2.3-11.P2.fc16.i686 has missing requires of libdns-export.so.81
12:dhcp-4.2.3-11.P2.fc16.i686 has missing requires of libisc-export.so.83
facter-1.6.6-1.fc16.i686 has missing requires of ruby(abi) = ('0', '1.8', None)
farsight2-python-0.0.31-1.fc16.i686 has missing requires of farsight2 = ('0', '0.0.31', '1.fc16')
farsight2-python-0.0.31-1.fc16.i686 has missing requires of libgstfarsight-0.10.so.0
gcc-objc-4.6.3-2.fc16.i686 has missing requires of gcc = ('0', '4.6.3', '2.fc16')
gcc-objc-4.6.3-2.fc16.i686 has missing requires of libgmp.so.3
gcc-objc++-4.6.3-2.fc16.i686 has missing requires of gcc-c++ = ('0', '4.6.3', '2.fc16')
gcc-objc++-4.6.3-2.fc16.i686 has missing requires of libgmp.so.3
gnome-user-share-3.0.1-1.fc16.i686 has missing requires of libgnome-bluetooth.so.8
5:guile-devel-1.8.8-3.fc16.i686 has missing requires of guile = ('5', '1.8.8', '3.fc16')
ibus-chewing-1.4.0-1.fc16.i686 has missing requires of libibus-1.0.so.0
ibus-hangul-1.4.1-4.fc16.i686 has missing requires of libibus-1.0.so.0
libcompizconfig-0.9.5.92-1.fc16.i686 has missing requires of libboost_serialization-mt.so.1.47.0
libgcj-4.6.3-2.fc16.i686 has missing requires of libgmp.so.3
libldb-devel-1.1.0-1.fc16.i686 has missing requires of libldb = ('0', '1.1.0', '1.fc16')
libproxy-python-0.4.7-1.fc16.noarch has missing requires of libproxy = ('0', '0.4.7', '1.fc16')
libpurple-2.10.5-1.fc16.i686 has missing requires of libgstfarsight-0.10.so.0
libreport-plugin-reportuploader-2.0.10-3.fc16.i686 has missing requires of libreport = ('0', '2.0.10', '3.fc16')
librsync-devel-0.9.7-16.fc15.i686 has missing requires of librsync = ('0', '0.9.7', '16.fc15')
libselinux-ruby-2.1.6-6.fc16.i686 has missing requires of libselinux = ('0', '2.1.6', '6.fc16')
libstdc++-static-4.6.3-2.fc16.i686 has missing requires of libstdc++-devel = ('0', '4.6.3', '2.fc16')
libtalloc-devel-2.0.7-4.fc16.i686 has missing requires of libtalloc = ('0', '2.0.7', '4.fc16')
libtdb-devel-1.2.9-10.fc16.i686 has missing requires of libtdb = ('0', '1.2.9', '10.fc16')
libtevent-devel-0.9.15-1.fc16.i686 has missing requires of libtevent = ('0', '0.9.15', '1.fc16')
lua-devel-5.1.4-9.fc16.i686 has missing requires of lua = ('0', '5.1.4', '9.fc16')
lua-static-5.1.4-9.fc16.i686 has missing requires of lua = ('0', '5.1.4', '9.fc16')
1:net-snmp-utils-5.7.1-2.fc16.i686 has missing requires of net-snmp-libs = ('1', '5.7.1', '2.fc16')
2:ntfs-3g-devel-2011.4.12-5.fc16.i686 has missing requires of libntfs-3g.so.81
2:ntfs-3g-devel-2011.4.12-5.fc16.i686 has missing requires of ntfs-3g = ('2', '2011.4.12', '5.fc16')
php-bcmath-5.3.15-1.fc16.i686 has missing requires of php-common(x86-32) = ('0', '5.3.15', '1.fc16')
php-gd-5.3.15-1.fc16.i686 has missing requires of php-common(x86-32) = ('0', '5.3.15', '1.fc16')
php-process-5.3.15-1.fc16.i686 has missing requires of php-common(x86-32) = ('0', '5.3.15', '1.fc16')
php-xml-5.3.15-1.fc16.i686 has missing requires of php-common(x86-32) = ('0', '5.3.15', '1.fc16')
policycoreutils-gui-2.1.4-17.fc16.i686 has missing requires of policycoreutils-python = ('0', '2.1.4', '17.fc16')
pulseaudio-module-gconf-0.9.23-1.fc16.i686 has missing requires of libpulsecommon-0.9.23.so
pulseaudio-module-gconf-0.9.23-1.fc16.i686 has missing requires of libpulsecore-0.9.23.so
pulseaudio-module-gconf-0.9.23-1.fc16.i686 has missing requires of pulseaudio = ('0', '0.9.23', '1.fc16')
puppet-2.6.17-2.fc16.noarch has missing requires of ruby(abi) = ('0', '1.8', None)
pyclutter-1.3.2-2.fc15.i686 has missing requires of libclutter-glx-1.0.so.0
pyldb-1.1.0-1.fc16.i686 has missing requires of libldb = ('0', '1.1.0', '1.fc16')
python-caribou-0.4.1-3.fc16.noarch has missing requires of caribou = ('0', '0.4.1', '3.fc16')
python-tdb-1.2.9-10.fc16.i686 has missing requires of libtdb = ('0', '1.2.9', '10.fc16')
qtparted-0.4.5-26.fc15.i686 has missing requires of libparted.so.0
ruby-1.8.7.358-2.fc16.i686 has missing requires of libruby.so.1.8
ruby-1.8.7.358-2.fc16.i686 has missing requires of ruby-libs(x86-32) = ('0', '1.8.7.358', '2.fc16')
ruby-augeas-0.4.1-1.fc16.i686 has missing requires of libruby.so.1.8
ruby-augeas-0.4.1-1.fc16.i686 has missing requires of ruby(abi) = ('0', '1.8', None)
ruby-shadow-1.4.1-14.fc15.i686 has missing requires of libruby.so.1.8
ruby-shadow-1.4.1-14.fc15.i686 has missing requires of ruby(abi) = ('0', '1.8', None)
1:samba-swat-3.6.6-89.fc16.i686 has missing requires of samba = ('1', '3.6.6', '89.fc16')
2:samba4-client-4.0.0-47alpha18.fc17.i686 has installed conflicts samba-client < ('2', '3.9.9', None): 2:samba-client-3.6.5-86.fc17.1.i686
2:samba4-common-4.0.0-47alpha18.fc17.i686 has installed conflicts samba-common < ('2', '3.9.9', None): 2:samba-common-3.6.5-86.fc17.1.i686
samba4-devel-4.0.0-38.alpha16.fc16.i686 has missing requires of libpolicy.so.0
samba4-devel-4.0.0-38.alpha16.fc16.i686 has missing requires of libtorture.so.0
samba4-devel-4.0.0-38.alpha16.fc16.i686 has missing requires of samba4-libs = ('0', '4.0.0', '38.alpha16.fc16')
setools-console-3.3.7-19.fc16.i686 has missing requires of setools-libs = ('0', '3.3.7', '19.fc16')
spice-gtk-0.11-4.fc16.i686 has missing requires of spice-glib(x86-32) = ('0', '0.11', '4.fc16')
sssd-1.8.4-13.fc16.i686 has missing requires of libldb(x86-32) = ('0', '1.1.0', None)
system-config-network-1.6.3-1.fc16.noarch has missing requires of system-config-network-tui = ('0', '1.6.3', '1.fc16')
testdisk-6.12-1.fc16.i686 has missing requires of libntfs-3g.so.81
2:vim-enhanced-7.3.515-2.fc16.i686 has missing requires of libruby.so.1.8
xen-runtime-4.1.2-9.fc16.i686 has missing requires of xen-libs = ('0', '4.1.2', '9.fc16')
xorg-x11-drv-apm-1.2.3-8.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-glint-1.2.5-2.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-i128-1.3.4-9.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-i740-1.3.2-9.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-intel-2.19.0-3.fc16.i686 has missing requires of libxcb-aux.so.0
xorg-x11-drv-intel-2.19.0-3.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-keyboard-1.6.0-2.fc16.i686 has missing requires of xserver-abi(xinput-13) >= ('0', '0', None)
xorg-x11-drv-mach64-6.9.0-2.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-mouse-1.7.1-2.fc16.i686 has missing requires of xserver-abi(xinput-13) >= ('0', '0', None)
xorg-x11-drv-nv-2.1.18-8.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-r128-6.8.1-11.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-rendition-4.2.4-7.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-s3virge-1.10.4-9.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-savage-2.3.3-1.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-siliconmotion-1.7.5-2.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-sis-0.10.3-7.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-sisusb-0.9.4-7.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-tdfx-1.4.3-9.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-trident-1.3.4-7.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-v4l-0.2.0-14.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
xorg-x11-drv-voodoo-1.2.4-7.fc16.i686 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-08-02.21-51.FK8gns.yumtx

Expected results:


Additional info:
Comment 1 Fedora End Of Life 2013-04-03 12:56:00 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 2 Fedora End Of Life 2015-01-09 12:17:34 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 3 Fedora End Of Life 2015-02-17 09:22:53 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.