Bug 845242 - Afr should unwind with correct pre/post parent bufs even when the fop on read-child fails
Afr should unwind with correct pre/post parent bufs even when the fop on read...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Pranith Kumar K
spandura
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 08:47 EDT by Pranith Kumar K
Modified: 2013-07-24 13:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:12:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2012-08-02 08:47:51 EDT
Description of problem:

In case of dir fops create, mknod, mkdir, link, symlink, rename
    if the fop fails on read-child then unwinds are happening with
    all-zero pre/post iatt-bufs. The bug occurs because the parent
    bufs are not saved if the response is not from read-child.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Pranith Kumar K 2012-11-01 07:54:55 EDT
http://review.gluster.com/3775

Note You need to log in before you can comment on or make changes to this bug.