Bug 845272 - XFCE strange mouse grapping behavior and mouse offset
XFCE strange mouse grapping behavior and mouse offset
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfce4-session (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 10:12 EDT by torkildj
Modified: 2012-08-11 23:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-11 23:24:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Video of the problem described (2.07 MB, video/webm)
2012-08-02 10:12 EDT, torkildj
no flags Details

  None (edit)
Description torkildj 2012-08-02 10:12:01 EDT
Created attachment 601957 [details]
Video of the problem described

When using GTK application as gThumb og Audacious. When holding left mouse button around toolbar area, it will enter grabbing mode, this works fine. However after having moved the window and put it where you want, then left clicking (for interacting with the program) anywhere inside window will trigger grabbing mode again (why? seems very strange behavior) and this time the mouse will have a huge offset compared to the window its moving around. Sometimes the window is so far offset that it will be outside the visible area of the screen. I have not been able to find any related setting that i could change to make this behavior go away. If you use the titlebar of the window for moving window, this behavior does not happen.

Using Fedora 17 (64bit version). Bug observed using several different machines with different graphical setup
1. NVIDIA official driver
2. radeon opensource driver
3. on VNC desktop without any acceleration

I have attached a video of the problem. Hope you can figure out what is happening.
Comment 1 Kevin Fenzi 2012-08-03 23:28:47 EDT
Odd. I don't see this behavior at all here with 4.10. 

Can you try creating a new user and see if the behavior persists there? That would tell us if it's a per user setting or a system wide issue there. 

What values do you have your focus settings set to?

If you would be willing to update one of your test machines to 4.10 ( http://repos.fedorapeople.org/repos/kevin/xfce-4.10/ ) we could also see if it's something that doesn't happen in 4.10 (although I didn't notice this behavior in 4.8 either that I recall).
Comment 2 torkildj 2012-08-04 04:54:40 EDT
I am using XFCE on two systems. Work and home. Both have a fresh fedora 17 64bit installation. I tried to create a new testuser and i get exactly the same behavior. I will try to update to xfce-4.10 and see if this solves the problem.
Comment 3 torkildj 2012-08-04 05:01:37 EDT
Upgrading to xfce-4.10 did not help. Notice that the behavior is only for all applications, but seems limited to a number of GTK applications. ie: Transmission, Audacious, gThumb

I am now using LXDE, which do not have this behavior for these applications. So it seems to be something with how XFCE handle these applications.
Comment 4 torkildj 2012-08-04 05:02:28 EDT
"only for all" -> not for all
Comment 5 Kevin Fenzi 2012-08-07 19:08:24 EDT
Strange. Would you be willing to report this upstream? 

if not, I can do so, but if you do, you will be better able to try things, etc without waiting for me as a go-between. ;) 

bugzilla.xfce.org. 

Let me know if you would prefer for me to file it... 

Thanks
Comment 6 torkildj 2012-08-08 03:14:30 EDT
I already filed it at bugzilla.xfce.org (same title and description as this one). I cannot find it for you, since bugzilla.xfce.org is down right now. I choose to file it at bugzilla.redhat.com since i waited several days without a reply (from XFCE) and i thought the problem could be specific to Fedora.
If possible it could be great if you could make them hurry to look at this issue, since its highly annoying when using those programs affected.
Comment 7 Kevin Fenzi 2012-08-08 11:34:50 EDT
ok. It looks like bugzilla.xfce.org is back up now... if you could find the bug I'll link them and see if we can get it moving. 

Thanks.
Comment 8 torkildj 2012-08-08 13:43:06 EDT
Actually just now they updated the bug and it turns out its a duplicate of a recently fixed issue. dont know if you can push the fix to your xfce-4.10 repository?
My ticket: https://bugzilla.xfce.org/show_bug.cgi?id=9115
duplicate of: https://bugzilla.xfce.org/show_bug.cgi?id=8949

Thank you for the help so far!
Comment 9 Kevin Fenzi 2012-08-11 20:44:45 EDT
Yep. Will try and build versions with the patch later today. ;) 

Thanks for tracking this down...
Comment 10 Kevin Fenzi 2012-08-11 23:24:55 EDT
ok, rawhide and xfce-4.10 side repos updated. 

Please do reopen this if you see any further issues with this bug.

Note You need to log in before you can comment on or make changes to this bug.