Bug 845285 - cgroups memory controller not present
cgroups memory controller not present
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 10:40 EDT by Daniel Berrange
Modified: 2012-08-02 13:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-02 13:14:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2012-08-02 10:40:41 EDT
Description of problem:
Boot latest rawde kernels  and you'll find the cgroups memory controller is missing

It appears the kcofnig variables have been renamed

   https://lkml.org/lkml/2012/6/26/365

Version-Release number of selected component (if applicable):
3.6.0-0.rc0.git8.1.fc18 

How reproducible:
Always

Steps to Reproduce:
1. cat /proc/cgroups
2.
3.
  
Actual results:
memory controller is missing

Expected results:
memory controller is present

Additional info:
Comment 1 Daniel Berrange 2012-08-02 10:47:16 EDT
IIUC, this should fix it, but not tested a build yet...

diff --git a/config-generic b/config-generic
index 3ac2ba9..20024fb 100644
--- a/config-generic
+++ b/config-generic
@@ -3926,10 +3926,10 @@ CONFIG_CGROUP_CPUACCT=y
 CONFIG_CGROUP_DEVICE=y
 CONFIG_CGROUP_FREEZER=y
 CONFIG_CGROUP_SCHED=y
-CONFIG_CGROUP_MEM_RES_CTLR=y
-CONFIG_CGROUP_MEM_RES_CTLR_SWAP=y # XXX disabled by default, pass 'swapaccount'
-# CONFIG_CGROUP_MEM_RES_CTLR_SWAP_ENABLED is not set
-CONFIG_CGROUP_MEM_RES_CTLR_KMEM=y
+CONFIG_MEMCG=y
+CONFIG_MEMCG_SWAP=y # XXX disabled by default, pass 'swapaccount'
+# CONFIG_MEMCG_SWAP_ENABLED is not set
+CONFIG_MEMCG_KMEM=y
 # CONFIG_CGROUP_HUGETLB is not set
 CONFIG_CGROUP_PERF=y
 CONFIG_BLK_CGROUP=y
Comment 2 Josh Boyer 2012-08-02 11:00:46 EDT
Sigh.  Thank you for spotting this.

I actually read the help text for CONFIG_MEMCG but didn't realize it was a rename.  The blurbs about memory and fork/exit overhead made me leave it off.  I guess I'll just flip it back on since we already had it enabled.
Comment 3 Josh Boyer 2012-08-02 13:14:02 EDT
Fixed in git.  Should be in tomorrow's rawhide.

Note You need to log in before you can comment on or make changes to this bug.