Bug 845304 - translation of the word "[OPTIONS]" has reverted
translation of the word "[OPTIONS]" has reverted
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
: Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-02 11:23 EDT by John Sefler
Modified: 2013-01-07 22:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:58:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-08-02 11:23:56 EDT
Description of problem:
Note sure how you are using the msgstr/msgid pairs, but the word for OPTIONS was translated and is now not translated.

you can see in https://bugzilla.redhat.com/show_bug.cgi?id=839807#c0 that [OPTIONS] was translated and now it is not (see below).

Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.11-1.git.11.4d6cb5a.el5


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel59 ~]# for L in en_US de_DE es_ES fr_FR it_IT ja_JP ko_KR pt_BR ru_RU zh_CN zh_TW as_IN bn_IN hi_IN mr_IN gu_IN kn_IN ml_IN or_IN pa_IN ta_IN te_IN; do echo ""; echo "# LANG=$L.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'"; LANG=$L.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'; done;

# LANG=en_US.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Usage: subscription-manager register [OPTIONS]

# LANG=de_DE.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Verbrauch: subscription-manager register [OPTIONS]

# LANG=es_ES.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Uso: subscription-manager register [OPTIONS]

# LANG=fr_FR.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Utilisation : subscription-manager register [OPTIONS]

# LANG=it_IT.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Utilizzo: subscription-manager register [OPTIONS]

# LANG=ja_JP.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
使用法: subscription-manager register [OPTIONS]

# LANG=ko_KR.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
사용법: subscription-manager register [OPTIONS]

# LANG=pt_BR.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Uso: subscription-manager register [OPTIONS]

# LANG=ru_RU.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Формат: subscription-manager register [OPTIONS]

# LANG=zh_CN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
使用:subscription-manager register [OPTIONS]

# LANG=zh_TW.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
使用方法:subscription-manager register [OPTIONS]

# LANG=as_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ব্যৱহাৰ: subscription-manager register [OPTIONS]

# LANG=bn_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ব্যবহারপ্রণালী: subscription-manager register [OPTIONS]

# LANG=hi_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
प्रयोग: subscription-manager register [OPTIONS]

# LANG=mr_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
वपार: subscription-manager register [OPTIONS]

# LANG=gu_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
વપરાશ: subscription-manager register [OPTIONS]

# LANG=kn_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ಬಳಕೆ: subscription-manager register [OPTIONS]

# LANG=ml_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ഉപയോഗിയ്ക്കേണ്ട വിധം: subscription-manager register [OPTIONS]

# LANG=or_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ଉପଯୋଗ: subscription-manager register [OPTIONS]

# LANG=pa_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ਵਰਤੋਂ: subscription-manager register [OPTIONS]

# LANG=ta_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
பயன்பாடு: subscription-manager register [OPTIONS]

# LANG=te_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
వా‍డుక: subscription-manager register [OPTIONS]
[root@jsefler-rhel59 ~]# 


^^^ THE WORD OPTIONS IS NOT TRANSLATED IN ANY LANGUAGE FOR THESE USAGE MESSAGES


Let's look at italian as one example....
[root@jsefler-rhel59 ~]# msgunfmt /usr/share/locale/it/LC_MESSAGES/rhsm.mo | grep -A1 OPTIONS
msgid "%s [OPTIONS]"
msgstr "%s [OPTIONS]"

--
msgid "Usage: %s MODULE-NAME [MODULE-OPTIONS] [--help]"
msgstr "Utilizzo: %s NOME-MODULO [OPZIONI-MODULO] [--help]"
--
msgid "usage: %%prog %s [OPTIONS]"
msgstr "utilizzo: %%prog %s [OPZIONI]"


Clearly, OPZIONI is a valid translation for OPTIONS, but the msgid "%s [OPTIONS]" is not translated.  This must be the one being used. 

Do we need to wait on another round of translations?
Comment 1 RHEL Product and Program Management 2012-08-02 11:28:42 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Adrian Likins 2012-09-04 13:14:17 EDT
This seems to be getting fixed as latest translations are coming in. 
Will move to modified when those are pushed.
Comment 3 Adrian Likins 2012-10-05 11:03:02 EDT
Latest translations are in
Comment 5 John Sefler 2012-10-07 13:14:38 EDT
>>>>> And, TBH, I need a formal answer on if [OPTIONS] should be
>>>>> translated:
>>>>
>>>> TBH, there is no clear and simple answer to this question,
>>>> because of following reasons.
>>>>
>>>> * Translators (who understands their language well) decide what should
>>>> be translated, transliterated or left in English.
>>>> * For Indic languages, local language words do not render well,
>>>> that's also the reason some of the translators do not translate these kind
>>>> of messages
>>>> * In some cases, whenever it is *Commands* we simply leave them in
>>>> English to maintain consistency across translations (for a particular
>>>> language) for translations of commands-like messages.
>>>>
>>>> If a translator acknowledges some translations to be correct, it is
>>>> correct. So, if you want I can ask each individual language
>>>> translator to confirm over their translations in Bugzilla OR modify it.
>>>>
>>>> Thanks!
>>>> Ankit

^ Based on this input from Ankit, I will tolerate both english and non-english translations for the word "[OPTIONS]" even when a translation existed in past builds and has been reverted back to english.  In the following build, we have a mix...

[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.21-1.el5

[root@jsefler-rhel59 ~]# for L in en_US de_DE es_ES fr_FR it_IT ja_JP ko_KR pt_BR ru_RU zh_CN zh_TW as_IN bn_IN hi_IN mr_IN gu_IN kn_IN ml_IN or_IN pa_IN ta_IN te_IN; do echo ""; echo "# LANG=$L.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'"; LANG=$L.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'; done;

# LANG=en_US.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Usage: subscription-manager register [OPTIONS]

# LANG=de_DE.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Verwendung: subscription-manager register [OPTIONEN]

# LANG=es_ES.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Uso: subscription-manager register [OPCIONES]

# LANG=fr_FR.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Utilisation : subscription-manager register [OPTIONS]

# LANG=it_IT.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Utilizzo: subscription-manager register [OPTIONS]

# LANG=ja_JP.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
使用法: subscription-manager register [オプション]

# LANG=ko_KR.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
사용법: subscription-manager register [OPTIONS]

# LANG=pt_BR.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Uso: subscription-manager register [OPTIONS]

# LANG=ru_RU.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
Формат: subscription-manager register [ПАРАМЕТРЫ]

# LANG=zh_CN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
使用:subscription-manager register [选项]

# LANG=zh_TW.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
使用方法:subscription-manager register [OPTIONS]

# LANG=as_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ব্যৱহাৰ: subscription-manager register [বিকল্পসমূহ]

# LANG=bn_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ব্যবহারপ্রণালী: subscription-manager register [OPTIONS]

# LANG=hi_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
प्रयोग: subscription-manager register [OPTIONS]

# LANG=mr_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
वपार: subscription-manager register [पर्याय]

# LANG=gu_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
વપરાશ: subscription-manager register [OPTIONS]

# LANG=kn_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ಬಳಕೆ: subscription-manager register [ಆಯ್ಕೆಗಳು]

# LANG=ml_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ഉപയോഗിയ്ക്കേണ്ട വിധം: subscription-manager register [ഐച്ഛികങ്ങള്‍]

# LANG=or_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ଉପଯୋଗ: subscription-manager register [OPTIONS]

# LANG=pa_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
ਵਰਤੋਂ: subscription-manager register [OPTIONS]

# LANG=ta_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
பயன்பாடு: subscription-manager register [OPTIONS]

# LANG=te_IN.UTF-8 subscription-manager register --help | grep -- 'subscription-manager register'
వా‍డుక: subscription-manager register [OPTIONS]


Moving to VERIFIED
Comment 7 errata-xmlrpc 2013-01-07 22:58:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.