Bug 845327 - Incorrect argument in consumer unregister
Incorrect argument in consumer unregister
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Sprint 39
Assigned To: Sayli Karmarkar
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 12:52 EDT by Jay Dobies
Modified: 2015-03-22 21:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 12:05:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2012-08-02 12:52:06 EDT
╭─[jdob]─[hinterlands]─[~]─[]─●
╰─➤ pulp-admin consumer unregister                  
Command: unregister
Description: unregisters a consumer

Available Arguments:

  --id - (required) identifies the consumer to be unregistered

The following options are required but were not specified:
  --id


Since ID is used so much, we made the decision to always quantify it. Please change to --consumer-id and make sure to update the user guide.
Comment 1 Sayli Karmarkar 2012-08-08 17:24:05 EDT
commit 5196eb36b3c83f43c56e69069280cc9b729989cc
Author: Sayli Karmarkar <skarmark@redhat.com>
Date:   Wed Aug 8 14:22:33 2012 -0700

    845327 - changing basic consumer extension commands like unregister, update etc. to accept --consumer-id as an option instead of --id
Comment 2 Jeff Ortel 2012-08-09 09:37:00 EDT
build: 0.322
Comment 3 Preethi Thomas 2012-08-15 11:27:45 EDT
verified
[root@pulp-master ~]# rpm -q pulp-server
pulp-server-0.0.323-1.fc17.noarch
[root@pulp-master ~]# 

[root@pulp-master ~]# pulp-admin consumer  unregister
Command: unregister
Description: unregisters a consumer

Available Arguments:

  --consumer-id - (required) identifies the consumer to be unregistered

The following options are required but were not specified:
  --consumer-id
[root@pulp-master ~]#
Comment 4 Preethi Thomas 2013-01-09 12:05:41 EST
Pulp v2.0 released

Note You need to log in before you can comment on or make changes to this bug.