Bug 845396 - ixgbe's VF existence check incorrect
ixgbe's VF existence check incorrect
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Andy Gospodarek
Red Hat Kernel QE team
:
Depends On:
Blocks: 845397
  Show dependency treegraph
 
Reported: 2012-08-02 19:32 EDT by Don Dutile
Modified: 2014-06-29 19:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 845397 (view as bug list)
Environment:
Last Closed: 2013-04-23 13:35:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Dutile 2012-08-02 19:32:09 EDT
Description of problem:
When ixgbe's Physical Function(PF) probe is executed and it's SRIOV functionality is enabled, it does a check to see if VF devices already exist in the system due to a previous driver load/unload with VFs enabled.  The existence check is incorrect, and can erroneously match on VFs that are attached to other ixgbe PFs, and not the VF associated with the probe'd PF.

Version-Release number of selected component (if applicable):


How reproducible:
Always with multipel ixgbe's in different PCI busses, but same PCI slot numbers, e.g. ixgbe at 07:00.0, ixgbe at 04:00.0

Steps to Reproduce:
1. Boot system
2. rmmod ixgbe; modprobe ixgbe=max_vfs=2
3. Ensure all 10GigE links are configured to a 10Gig switch
  
Actual results:
VFs associated with second ixgbe won't configure in, since the VF-matching check will match the first PF's VFs as being the second PF's VFs, incorrectly.

Expected results:
All VFs configure and work.

Additional info:
Need to backport this upstream commit to rhel6.3:
commit 9297127b9cdd8d30c829ef5fd28b7cc0323a7bcd
Author: Alexander Duyck <alexander.h.duyck@intel.com>
Date:   Wed May 23 02:58:40 2012 +0000

    ixgbe: Change how we check for pre-existing and assigned VFs
Comment 2 RHEL Product and Program Management 2012-12-14 03:52:54 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.