Bug 845398 - igb's VF existence check is broken
igb's VF existence check is broken
Status: CLOSED DUPLICATE of bug 819102
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Stefan Assmann
Red Hat Kernel QE team
:
Depends On:
Blocks: 845399
  Show dependency treegraph
 
Reported: 2012-08-02 19:41 EDT by Don Dutile
Modified: 2012-09-21 02:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 845399 (view as bug list)
Environment:
Last Closed: 2012-09-21 02:53:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Dutile 2012-08-02 19:41:33 EDT
Description of problem:
When igb's Physical Function(PF) probe is executed and it's SRIOV functionality is enabled, it does a check to see if VF devices already exist in the system due to a previous driver load/unload with VFs enabled.  The existence check is incorrect, and can erroneously match on VFs that are attached to other ixgbe PFs, and not the VF associated with the probe'd PF.

Version-Release number of selected component (if applicable):


How reproducible:
Always with multiple igb's in different PCI busses, but same PCI slot numbers, e.g. igb at 07:00.0, igb at 04:00.0

Steps to Reproduce:
1. Boot system
2. rmmod igb; modprobe igb max_vfs=2
3. 
  
Actual results:
VFs associated with second igb won't configure in, since the VF-matching check will match the first PF's VFs as being the second PF's VFs, incorrectly.

Expected results:
All VFs configure and work.

Additional info:
Intel is testing a patch provided by Stefan Assmann.
It is similar in form to the following patch for ixgbe:
Need to backport this upstream commit to rhel6.3:
commit 9297127b9cdd8d30c829ef5fd28b7cc0323a7bcd
Author: Alexander Duyck <alexander.h.duyck@intel.com>
Date:   Wed May 23 02:58:40 2012 +0000

    ixgbe: Change how we check for pre-existing and assigned VFsDescription of problem:


Upstream igb is broken as well, and the patch Stefan provided will be pushed to upstream if testing shows positive results.
Comment 2 Stefan Assmann 2012-09-21 02:53:28 EDT

*** This bug has been marked as a duplicate of bug 819102 ***

Note You need to log in before you can comment on or make changes to this bug.