Bug 845423 - [abrt] calibre-0.8.50-1.fc17: Image.py:401:_getencoder:IOError: encoder jpeg not available
[abrt] calibre-0.8.50-1.fc17: Image.py:401:_getencoder:IOError: encoder jpeg ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
abrt_hash:dabca6e4ecff49ed4b87d210e95...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 00:21 EDT by tonyseek
Modified: 2012-10-06 13:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-06 13:30:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tonyseek 2012-08-03 00:21:24 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        python2 /usr/bin/calibre-parallel
comment:        The libjpeg-devel has not been installed while compile PIL. I think a tips information should be given in this time.
executable:     /usr/bin/calibre-parallel
kernel:         3.4.6-2.fc17.x86_64
time:           2012年08月03日 星期五 12时13分16秒
uid:            1000

backtrace:
:Image.py:401:_getencoder:IOError: encoder jpeg not available
:
:Traceback (most recent call last):
:  File "/usr/bin/calibre-parallel", line 19, in <module>
:    sys.exit(main())
:  File "/usr/lib64/calibre/calibre/utils/ipc/worker.py", line 190, in main
:    result = func(*args, **kwargs)
:  File "/usr/lib64/calibre/calibre/gui2/convert/gui_conversion.py", line 31, in gui_convert_override
:    override_input_metadata=True)
:  File "/usr/lib64/calibre/calibre/gui2/convert/gui_conversion.py", line 25, in gui_convert
:    plumber.run()
:  File "/usr/lib64/calibre/calibre/ebooks/conversion/plumber.py", line 972, in run
:    accelerators, tdir)
:  File "/usr/lib64/calibre/calibre/customize/conversion.py", line 208, in __call__
:    log, accelerators)
:  File "/usr/lib64/calibre/calibre/ebooks/conversion/plugins/mobi_input.py", line 34, in convert
:    mr.extract_content(u'.', parse_cache)
:  File "/usr/lib64/calibre/calibre/ebooks/mobi/reader/mobi6.py", line 171, in extract_content
:    self.extract_images(processed_records, output_dir)
:  File "/usr/lib64/calibre/calibre/ebooks/mobi/reader/mobi6.py", line 858, in extract_images
:    im.save(open(path, 'wb'), format='JPEG')
:  File "/usr/lib64/python2.7/site-packages/PIL/Image.py", line 1439, in save
:    save_handler(self, fp, filename)
:  File "/usr/lib64/python2.7/site-packages/PIL/JpegImagePlugin.py", line 471, in _save
:    ImageFile._save(im, fp, [("jpeg", (0,0)+im.size, 0, rawmode)])
:  File "/usr/lib64/python2.7/site-packages/PIL/ImageFile.py", line 495, in _save
:    e = Image._getencoder(im.mode, e, a, im.encoderconfig)
:  File "/usr/lib64/python2.7/site-packages/PIL/Image.py", line 401, in _getencoder
:    raise IOError("encoder %s not available" % encoder_name)
:IOError: encoder jpeg not available
:
:Local variables in innermost frame:
:args: ('RGB',)
:mode: 'RGB'
:encoder_name: 'jpeg'
:extra: (0, False, 0, False, 0, 0, 0, -1, '')
Comment 1 Kevin Fenzi 2012-08-03 12:03:00 EDT
Is libjpeg-turbo installed?

Does 'yum check' show any issues?
Comment 2 tonyseek 2012-08-03 12:10:10 EDT
Yes, the problem is libjpeg-turbo-devel had not been install while I installing PIL with pip.

I thought may it give a human-readable message after the problems about losing encoder happened?

(In reply to comment #1)
> Is libjpeg-turbo installed?
> 
> Does 'yum check' show any issues?
Comment 3 Kevin Fenzi 2012-08-03 17:00:50 EDT
I don't think upstream has too many plans to change the error handling. ;( 

It's going to traceback like that when something it needs is missing, so not sure what I can do here for you. ;(

Note You need to log in before you can comment on or make changes to this bug.