Bug 845436 - ROOT.war is undeployed after server upgrade for an existing non-scaling jbossas-7 application
ROOT.war is undeployed after server upgrade for an existing non-scaling jboss...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 01:56 EDT by Jianwei Hou
Modified: 2015-05-14 18:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 16:42:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (5.68 KB, text/x-log)
2012-08-06 01:29 EDT, Jianwei Hou
no flags Details

  None (edit)
Description Jianwei Hou 2012-08-03 01:56:17 EDT
Description of problem:
After server upgrade, can not access jbosssas-7 application's website 

Version-Release number of selected component (if applicable):
on stage
Reproduce on devenv

How reproducible:
always

Steps to Reproduce:
1.Create a non-scaling jbossas-7 application before upgrade
2.do server upgrade and migrate
3.Access app's url, 
  
Actual results:
The app's url is blank
run rhc app status -a jbossas1 :

4c820df579a345eba530f60c9ce25be0
4c820df579a345eba530f60c9ce25be0
tailing /var/lib/stickshift/4c820df579a345eba530f60c9ce25be0/jbossas1//jbossas-7/standalone/log/server.log
------ Tail of jbossas1 application server.log ------
2012/08/02 12:52:01,883 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015877: Stopped deployment ROOT.war in 49ms
2012/08/02 12:52:01,895 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS018558: Undeployed "ROOT.war"

Expected results:
application should be accessible after upgrade

Additional info:
Make some change in app's repo and git push to make application built and deployed again, then the problem is gone.
For scalable jbossas-7 applications, this problem never exist.
Comment 1 Xiaoli Tian 2012-08-03 03:42:19 EDT
This happened for old jbossas7 application on stage after stage is upgraded.

Not sure if it's caused by the fix for this bug 844267.
Comment 2 Bill DeCoste 2012-08-03 15:04:14 EDT
ROOT.war should redeploy since it's a new file. Do you see it just undeploy and not redeploy?
Comment 3 Bill DeCoste 2012-08-03 15:15:30 EDT
can you send me attach server.log?
Comment 4 Bill DeCoste 2012-08-03 19:13:19 EDT
Migration modified to remove *.war.* after a sleep of 15. Should now see this:

2012/08/03 19:11:51,959 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015877: Stopped deployment ROOT.war in 736ms
2012/08/03 19:11:51,978 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-3) JBAS015876: Starting deployment of "ROOT.war"
2012/08/03 19:11:52,147 INFO  [org.jboss.web] (MSC service thread 1-4) JBAS018210: Registering web context: 
2012/08/03 19:11:52,167 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018565: Replaced deployment "ROOT.war" with deployment "ROOT.war"
2012/08/03 19:11:52,241 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018562: Redeployed "ROOT.war"

OR

An undeploy and a deploy
Comment 5 Jianwei Hou 2012-08-06 01:29:06 EDT
Created attachment 602409 [details]
server.log

Still can not access app's url after migrate

Steps to reproduce:
Lauch an old instance, devenv-stage_226
1. Create a non-scalable jbossas application
  rhc app create -a j1 -t jbossas-7
2. upgrade server to latest
  yum update
3. Access app's url, app is working fine
4. Run migrate
  git clone git@github.com:openshift/li.git
  cd /li/misc/maintenance/bin
  ./migrate-mongo-2.0.15
  rhc-admin-migrate --version 2.0.15
5. Check app's url again, the page is blank again.

seems ROOT.war is undeployed after migrate, see the followings:

[root@domU-12-31-39-0B-D9-73 standalone]# pwd
/var/lib/stickshift/bcf0be9930ae4b91af18e38131b060a3/jbossas-7/jbossas-7/standalone
[root@domU-12-31-39-0B-D9-73 standalone]# ll
total 20
drwxr-xr-x. 3 bcf0be9930ae4b91af18e38131b060a3 bcf0be9930ae4b91af18e38131b060a3 4096 Aug  6 00:41 configuration
drwxr-xr-x. 8 bcf0be9930ae4b91af18e38131b060a3 bcf0be9930ae4b91af18e38131b060a3 4096 Aug  6 00:20 data
lrwxrwxrwx. 1 root                             root                               78 Aug  6 00:41 deployments -> /var/lib/stickshift/bcf0be9930ae4b91af18e38131b060a3/app-root/repo/deployments
drwxr-xr-x. 2 bcf0be9930ae4b91af18e38131b060a3 bcf0be9930ae4b91af18e38131b060a3 4096 Aug  6 01:08 log
drwxr-xr-x. 5 bcf0be9930ae4b91af18e38131b060a3 bcf0be9930ae4b91af18e38131b060a3 4096 Aug  6 00:20 tmp
[root@domU-12-31-39-0B-D9-73 standalone]# ll deployments/
total 12
-rw-r-----. 1 bcf0be9930ae4b91af18e38131b060a3 bcf0be9930ae4b91af18e38131b060a3 8037 Aug  6 00:20 ROOT.war
-rw-r--r--. 1 bcf0be9930ae4b91af18e38131b060a3 bcf0be9930ae4b91af18e38131b060a3    8 Aug  6 00:41 ROOT.war.undeployed

After git push, everything works fine.

I have attached server.log
Comment 6 Xiaoli Tian 2012-08-06 21:26:31 EDT
Should be fixed in rhc-node-0.96.14 with devenv-stage_231, move it to ON_QA.
Comment 7 Jianwei Hou 2012-08-06 22:34:54 EDT
Verified with rhc-node-0.96.14

Steps:
Lauch an old instance, devenv-stage_226
1. Create a non-scalable jbossas application
  rhc app create -a jbossas1 -t jbossas-7
2. upgrade server to latest
  yum update
3. Access app's url, app is working fine
4. Run migrate
  git clone git@github.com:openshift/li.git
  cd /li/misc/maintenance/bin
  ./migrate-mongo-2.0.15
  rhc-admin-migrate --version 2.0.15
5. Check app's url again, app is working fine
6. ssh into application, check server.log, log files has infomation indicating ROOT.war is deployed.

2012/08/06 21:41:53,686 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "ROOT.war"
2012/08/06 21:41:54,992 INFO  [org.jboss.web] (MSC service thread 1-2) JBAS018210: Registering web context:
2012/08/06 21:41:55,176 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018559: Deployed "ROOT.war"
2012/08/06 22:16:12,281 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment ROOT.war in 43ms
2012/08/06 22:16:12,293 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018558: Undeployed "ROOT.war"
2012/08/06 22:16:22,322 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015876: Starting deployment of "ROOT.war"
2012/08/06 22:16:22,376 INFO  [org.jboss.web] (MSC service thread 1-2) JBAS018210: Registering web context:
2012/08/06 22:16:22,386 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS018559: Deployed "ROOT.war"

7. Try git push and jenkins build, everything works fine

Note You need to log in before you can comment on or make changes to this bug.