Bug 845481 - cannot remove virtio_net module correctly in rhel5.9 64bit guest
cannot remove virtio_net module correctly in rhel5.9 64bit guest
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.9
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 04:11 EDT by Sibiao Luo
Modified: 2013-03-28 14:58 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-28 14:58:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2012-08-03 04:11:58 EDT
Description of problem:
   Boot a rhel5.9 64bit guest with virtio NIC, but fail remove virtio_net module correctly in rhel5.9 64bit guest. The virtio_net module should be remove/add successfully if possible without any problem.
   BTW, if i remove 'alias eth0 virtio_net' from the /etc/modprobe.conf, and then test it with the same steps, the virtio_net module can be removed/added correctly.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q kvm
2.6.18-333.el5
kvm-83-258.el5
guest info:
# uname -r
2.6.18-333.el5

How reproducible:
almost every time

Steps to Reproduce:
1.boot a rhel5.9 64bit guest with virtio NIC.
eg: # <qemu-kvm-command>...-net nic,vlan=0,model=virtio,macaddr=08:2E:5F:0A:0D:0A -net tap,sndbuf=0,vlan=0,script=/etc/qemu-ifup,downscript=no
2.check the virtio module and network.
# lsmod | grep virtio
virtio_net             48705  0 
virtio_balloon         41025  0 
virtio_blk             42441  3 
virtio_pci             43593  0 
virtio_ring            37953  1 virtio_pci
virtio                 39365  4 virtio_net,virtio_balloon,virtio_blk,virtio_pci
# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 08:2E:5F:0A:0D:0A  
          inet addr:10.66.11.65  Bcast:10.66.11.255  Mask:255.255.252.0
...
# ping www.baidu.com -c 5
PING www.a.shifen.com (220.181.111.147) 56(84) bytes of data.
64 bytes from 220.181.111.147: icmp_seq=1 ttl=51 time=6.68 ms
64 bytes from 220.181.111.147: icmp_seq=2 ttl=51 time=7.46 ms
64 bytes from 220.181.111.147: icmp_seq=3 ttl=51 time=5.82 ms
64 bytes from 220.181.111.147: icmp_seq=4 ttl=51 time=15.5 ms
64 bytes from 220.181.111.147: icmp_seq=5 ttl=51 time=5.03 ms

--- www.a.shifen.com ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3999ms
rtt min/avg/max/mdev = 5.030/8.115/15.567/3.814 ms
3.remove the virtio_net module and check it.
# rmmod virtio_net / # modprobe -r virtio_net
  
Actual results:
after the step 3, the virtio_net module cannot be removed correctly, and it can obtain ip addr and can ping external network successfully.
# lsmod | grep virtio
virtio_net             48705  0 
virtio_balloon         41025  0 
virtio_blk             42441  3 
virtio_pci             43593  0 
virtio_ring            37953  1 virtio_pci
virtio                 39365  4 virtio_net,virtio_balloon,virtio_blk,virtio_pci
# ping www.baidu.com -c 5
PING www.a.shifen.com (220.181.111.147) 56(84) bytes of data.
64 bytes from 220.181.111.147: icmp_seq=1 ttl=51 time=9.91 ms
64 bytes from 220.181.111.147: icmp_seq=2 ttl=51 time=7.82 ms
64 bytes from 220.181.111.147: icmp_seq=3 ttl=51 time=5.50 ms
64 bytes from 220.181.111.147: icmp_seq=4 ttl=51 time=5.38 ms
64 bytes from 220.181.111.147: icmp_seq=5 ttl=51 time=4.93 ms

--- www.a.shifen.com ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4002ms
rtt min/avg/max/mdev = 4.933/6.711/9.912/1.891 ms

Expected results:
can remove the virtio_net module correctly, and the virtio NIC device cann't obtain ip addr and fail to ping external network.

Additional info:
if i remove the virtio_pci, the guest will Call Trace and prompt some error form serial console.
Comment 1 RHEL Product and Program Management 2012-08-03 04:28:53 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Sibiao Luo 2012-08-07 04:58:47 EDT
(In reply to comment #0)
> Description of problem:
>    Boot a rhel5.9 64bit guest with virtio NIC, but fail remove virtio_net
> module correctly in rhel5.9 64bit guest. The virtio_net module should be
> remove/add successfully if possible without any problem.
>    BTW, if i remove 'alias eth0 virtio_net' from the /etc/modprobe.conf, and
> then test it with the same steps, the virtio_net module can be removed/added
> correctly.
> 

Hi all,

   I also try the rhel5.8GA 64bit guest with the same CLI and steps, it also hit this issue, the virtio_net will reload automatically after remove it.

Best wish.
sluo
Comment 3 Ronen Hod 2012-08-08 15:30:14 EDT
Moving to 5.10 for now.
It is not a regression, no harm done, there is a workaround (remove 'alias eth0 virtio_net'), and no customer reported it.
Comment 4 Miya Chen 2012-08-10 09:01:28 EDT
Hi Sibiao, please try "rmmod eth0" or "modprobe -r eth0" in step#3, if it works, i think it should be closed as not a bug, thanks.
Comment 5 Sibiao Luo 2012-08-13 02:55:51 EDT
(In reply to comment #4)
> Hi Sibiao, please try "rmmod eth0" or "modprobe -r eth0" in step#3, if it
> works, i think it should be closed as not a bug, thanks.

Hi michen,

   I have tried it as your indication, it fail and the results as following.
------test 1------
# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 08:2E:5F:0A:0D:9A  
          inet addr:10.66.8.193  Bcast:10.66.11.255  Mask:255.255.252.0
          inet6 addr: fe80::a2e:5fff:fe0a:d9a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3215 errors:0 dropped:0 overruns:0 frame:0
          TX packets:244 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:320798 (313.2 KiB)  TX bytes:32454 (31.6 KiB)
# ping -c 2 www.baidu.com
PING www.a.shifen.com (220.181.111.147) 56(84) bytes of data.
64 bytes from 220.181.111.147: icmp_seq=1 ttl=51 time=16.1 ms
64 bytes from 220.181.111.147: icmp_seq=2 ttl=51 time=25.8 ms

--- www.a.shifen.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 16.119/20.972/25.826/4.855 ms
# rmmod eth0
ERROR: Module eth0 does not exist in /proc/modules

------test 2------
# modprobe -r eth0
# echo $?
0
# ping -c 4 www.baidu.com
PING www.a.shifen.com (220.181.111.147) 56(84) bytes of data.
64 bytes from 220.181.111.147: icmp_seq=1 ttl=51 time=10.4 ms
64 bytes from 220.181.111.147: icmp_seq=2 ttl=51 time=16.6 ms
64 bytes from 220.181.111.147: icmp_seq=3 ttl=51 time=16.7 ms
64 bytes from 220.181.111.147: icmp_seq=4 ttl=51 time=19.8 ms

--- www.a.shifen.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3000ms
rtt min/avg/max/mdev = 10.437/15.935/19.898/3.434 ms

Best wish.
sluo
Comment 6 Sibiao Luo 2012-08-13 03:18:33 EDT
(In reply to comment #4)
> Hi Sibiao, please try "rmmod eth0" or "modprobe -r eth0" in step#3, if it
> works, i think it should be closed as not a bug, thanks.

Hi michen,

   I also test the rhel6.4 guest on the rhel5.9 host, it has no this issue, the virtio_net can be removed and added correctly.

Thanks
sluo

Note You need to log in before you can comment on or make changes to this bug.