Bug 845533 - Legacy spicec client is not updated by virt-viewer when connecting to a guest through User Portal
Legacy spicec client is not updated by virt-viewer when connecting to a guest...
Status: CLOSED DUPLICATE of bug 846341
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-activex-win (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Arnon Gilboa
Desktop QE
spice
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 07:03 EDT by Marian Krcmarik
Modified: 2016-02-10 15:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 10:05:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2012-08-03 07:03:01 EDT
Description of problem:
Legacy spicec client is not updated by virt-viewer when connecting to a guest through User Portal. The guest session is opened in spicec client and no prompt dialog for updating client is displayed.
I used this build which was deployed to RHEVM by me: spice-client-msi-3.1-2 -> rhevm-spice-client-x64-cab-3.1-2.el6.noarch.rpm 
The files seem to be located correctly after install of the package. Installatin of virt-viewer from cab works correctly on clean Windows client.
I am not really familiar with update mechanism and where the problem can be located. Text version files are located and contain higher version number.

Version-Release number of selected component (if applicable):
spice-client-msi-3.1-2

How reproducible:
Always

Steps to Reproduce:
1. Open User portal of RHEVM with deployed rhevm-spice-client-x64/x86-cab package.
2. Click on Console button of running VM from Windows client with latest spicec installed through RHEVM3.0.
  
Actual results:
Session is open in spicec.

Expected results:
spicec should be updated to virt-viewer

Additional info:
Comment 1 Marian Krcmarik 2012-08-07 10:05:00 EDT

*** This bug has been marked as a duplicate of bug 846341 ***

Note You need to log in before you can comment on or make changes to this bug.