Bug 845543 - iwlwifi regression in 3.5.0-2: fail to flush all tx fifo queues / Command REPLY_ADD_STA failed: FW Error
iwlwifi regression in 3.5.0-2: fail to flush all tx fifo queues / Command REP...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 08:00 EDT by Michel Alexandre Salim
Modified: 2012-11-27 11:37 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 09:50:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log showing iwlwifi problems (165.59 KB, text/plain)
2012-08-03 08:00 EDT, Michel Alexandre Salim
no flags Details

  None (edit)
Description Michel Alexandre Salim 2012-08-03 08:00:24 EDT
Created attachment 602116 [details]
log showing iwlwifi problems

Description of problem:
The iwlwifi driver regressed to the point of being unusable in 3.5.0-2 -- after working fine in 3.4.4-5 and previous kernels, as well as 3.4.6-2.

iwlwifi would start writing verbosely to the logs (see attachment) towards the end of the boot process, repeating this sequence every about 12 seconds:

[   80.021498] iwlwifi 0000:02:00.0: BUG_ON, Stop restarting
[   83.702067] iwlwifi 0000:02:00.0: fail to flush all tx fifo queues
[   83.712025] iwlwifi 0000:02:00.0: Command REPLY_ADD_STA failed: FW Error

... and upon logging into GNOME, NetworkManager starts off with the network connection to my access point being disconnected. I could then reconnect but the system is much more sluggish than usual, and even when NM reports a connection it's not actually usable.

Version-Release number of selected component (if applicable):
kernel-3.5.0-2.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Reboot into this kernel
2. Observe log files for iwlwifi debug messages
3. Try and use a Wifi connection
  
Actual results:
Errors start filling the logs towards the end of the Plymouth splash screen sequence; dmesg shows repeated iwlwifi resets with a period of ~ 12 seconds; wifi connection unusable; system sluggish

Expected results:
No regression from 3.4.6-2

Additional info:
This is a Sony Vaio SA with the following wifi adapter (per lspci -nnvv):


02:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6230 [8086:0091] (rev 34)
        Subsystem: Intel Corporation Centrino Advanced-N 6230 AGN [8086:5201]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 50
        Region 0: Memory at c7400000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlwifi
Comment 1 John W. Linville 2012-08-03 09:06:42 EDT
Another ugly iwlwifi firmware crash...what information would be useful for Michel to collect?
Comment 2 Johannes Berg 2012-08-03 09:13:26 EDT
Wow, this is odd, I've never seen this before... I'll have to forward it internally, but I'm going to be on vacation next week and the week after.
Comment 3 Johannes Berg 2012-08-03 09:29:37 EDT
I guess there are only ~177 patches or so in iwlwifi between 3.4 and 3.5, but I'm not sure if you're willing to bisect?
Comment 4 Michel Alexandre Salim 2012-08-07 02:19:10 EDT
I can try bisecting, sure. Should I do that using the vanilla kernel sources or are there any Fedora-specific patches I need to add to the mix?

I can also try the latest pre-3.6.0 build for F18 and see if it's fixed there. Which do you prefer?
Comment 5 Jonas Thiem 2012-08-22 10:58:39 EDT
I have the same issue, but found a workaround:
Putting
  options iwlwifi 11n_disable=1
into /etc/modprobe.d/iwlwifi.conf
makes the issue disappear for me.

Got this idea from https://bugs.launchpad.net/ubuntu/+source/linux/+bug/876147 - no idea if that bug is directly related, I guess it probably isn't.
Comment 6 Michel Alexandre Salim 2012-09-16 01:53:28 EDT
Probably not -- as it turns out, mine is likely correlated with an imminent memory failure -- not long afterwards I started experiencing RPM database corruptions, and after lock-ups when attempting to reinstall I ran memtest and it reported failure around the 6G memory address.

After removing the affected module, 3.5.x kernel releases now work without a problem. Are there changes in the way 3.5.x's iwlwifi allocate memory, perchance?

Feel free to close this bug - setting NEEDINFO to the assignee
Comment 7 John W. Linville 2012-09-24 09:50:23 EDT
Michel, thanks for the report!  I'm glad to know that things are working better.  I'm going to close this for now, since it seems reasonably likely that the issue you experienced was the result of some bad hardware.
Comment 8 GWL 2012-11-27 05:54:38 EST
Hi the bug has not been resolved at all.
Still getting fail to flush all tx fifo queues on my Intel 6200N WiFi Card.
Comment 9 John W. Linville 2012-11-27 11:37:19 EST
GWL -- please open a new bug report specific to your situation.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.