Bug 845549 - User portal should pass FQDN to spice-xpi in GuestHostName variable
User portal should pass FQDN to spice-xpi in GuestHostName variable
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: Shahar Havivi
yeylon@redhat.com
virt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 08:10 EDT by Marian Krcmarik
Modified: 2016-04-18 02:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 16:54:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2012-08-03 08:10:11 EDT
Description of problem:
User portal should pass FQDN to spice-xpi in GuestHostName variable when guest machine is Windows type (at least). Now It passes only Domain Name (if IP is not known), but It used to passing FQDN (RHEVM3.0) since this variable is used as parameter of legacy usb controller which works guest <-> client over IP (requires direct connection) and the client will not discover guest since It is trying to connect to the DN instead of FQDN.

Version-Release number of selected component (if applicable):
RHEVM(si13)

How reproducible:
Always (if IP of guest is not known to RHEVM)

Steps to Reproduce:
1. Connect to a windows guest (without rhev agent).
  
Actual results:
Domain name is passed to spice-xpi, instead of FQDN.

Expected results:
FQDN of guest is passed to spice-xpi.

Additional info:
Comment 2 Itamar Heim 2012-08-09 16:46:51 EDT
is this with legacy usb configured for that guest?
what was the cluster level?
Comment 3 Marian Krcmarik 2012-08-09 18:38:13 EDT
(In reply to comment #2)
> is this with legacy usb configured for that guest?
Yes.
> what was the cluster level?
3.1
Comment 4 Shahar Havivi 2012-08-12 04:50:44 EDT
Marian,
I cannot reproduce this bug,
the current behavior is:
 if we have ip, we are sending ip.
else 
 if we have host name we use it else we use the vm name
 if we have the domain name (domain column in vm_static table) we are concatenating the host/vm name to it ie: hostname.mydomain.com

Is that true for you as well, or there is something that I am missing?
Thanks.
Comment 5 Marian Krcmarik 2012-08-15 16:54:02 EDT
(In reply to comment #4)
> Marian,
> I cannot reproduce this bug,
> the current behavior is:
>  if we have ip, we are sending ip.
> else 
>  if we have host name we use it else we use the vm name
>  if we have the domain name (domain column in vm_static table) we are
> concatenating the host/vm name to it ie: hostname.mydomain.com
> 
> Is that true for you as well, or there is something that I am missing?
> Thanks.

I am not able to reproduce on si 13.3 anymore, wondering something changed or not. Anyway closing as NOTABUG and If I hit it again I will reopen. Now It seems to work correctly.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.