Bug 845582 - SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the file /home/roddy/.grl-metadata-store.
SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the file /hom...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2982c1da6be13798d2fe8168ea0...
:
: 845584 845587 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 09:58 EDT by roddy
Modified: 2012-08-06 05:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 05:08:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description roddy 2012-08-03 09:58:21 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.x86_64
time:           ven. 03 août 2012 17:57:44 RET

description:
:SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the file /home/roddy/.grl-metadata-store.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that smbd should be allowed getattr access on the .grl-metadata-store file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep smbd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:smbd_t:s0
:Target Context                unconfined_u:object_r:gstreamer_home_t:s0
:Target Objects                /home/roddy/.grl-metadata-store [ file ]
:Source                        smbd
:Source Path                   /usr/sbin/smbd
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           samba-3.6.6-91.fc17.1.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-2.fc17.x86_64 #1
:                              SMP Mon Jul 30 14:48:59 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    ven. 03 août 2012 17:50:36 RET
:Last Seen                     ven. 03 août 2012 17:50:36 RET
:Local ID                      3073d019-bea1-4731-83bd-a7e1504c4570
:
:Raw Audit Messages
:type=AVC msg=audit(1344001836.205:114): avc:  denied  { getattr } for  pid=2642 comm="smbd" path="/home/roddy/.grl-metadata-store" dev="dm-2" ino=130729 scontext=system_u:system_r:smbd_t:s0 tcontext=unconfined_u:object_r:gstreamer_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1344001836.205:114): arch=x86_64 syscall=stat success=yes exit=0 a0=7f48bf4cb5c0 a1=7fffc29a35d0 a2=7fffc29a35d0 a3=7f48bec009b3 items=0 ppid=1085 pid=2642 auid=4294967295 uid=0 gid=0 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=4294967295 comm=smbd exe=/usr/sbin/smbd subj=system_u:system_r:smbd_t:s0 key=(null)
:
:Hash: smbd,smbd_t,gstreamer_home_t,file,getattr
:
:audit2allow
:
:#============= smbd_t ==============
:#!!!! This avc can be allowed using one of the these booleans:
:#     samba_export_all_ro, samba_enable_home_dirs, samba_export_all_rw
:
:allow smbd_t gstreamer_home_t:file getattr;
:
:audit2allow -R
:
:#============= smbd_t ==============
:#!!!! This avc can be allowed using one of the these booleans:
:#     samba_export_all_ro, samba_enable_home_dirs, samba_export_all_rw
:
:allow smbd_t gstreamer_home_t:file getattr;
:
Comment 1 Miroslav Grepl 2012-08-06 05:05:11 EDT
*** Bug 845584 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-08-06 05:05:59 EDT
*** Bug 845587 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2012-08-06 05:08:07 EDT
:#============= smbd_t ==============
:#!!!! This avc can be allowed using one of the these booleans:
:#     samba_export_all_ro, samba_enable_home_dirs, samba_export_all_rw


So execute

# setsebool -P <boolean_name> 1

You can read more using

# man samba_selinux

Note You need to log in before you can comment on or make changes to this bug.