Bug 845603 - aeolus-configure fails to create admin user
aeolus-configure fails to create admin user
Status: CLOSED WORKSFORME
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-all (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Mike Orazi
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 10:46 EDT by Aziza Karol
Modified: 2012-08-06 16:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 16:21:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aziza Karol 2012-08-03 10:46:22 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install aeolus
2.aeolus-configure ec2, mock -- no admin user is created.
conductor=> select  *  from users;
 id | login | email | crypted_password | first_name | last_name | quota_id | login_count | failed_login_count | last_request_at | current_login_at | last_log
in_at | current_login_ip | last_login_ip | created_at | updated_at 
----+-------+-------+------------------+------------+-----------+----------+-------------+--------------------+-----------------+------------------+---------
------+------------------+---------------+------------+------------
(0 rows)

3.aeolus-clean up
4.aeolus-configure ec2, mock --  admin user is created

#conductor=> select  *  from users;
 id | login |           email            |                                                                                         crypted_password          
                                                                               |  first_name   | last_name | quota_id | login_count | failed_login_count | la
st_request_at | current_login_at | last_login_at | current_login_ip | last_login_ip |        created_at         |        updated_at         
----+-------+----------------------------+-------------------------------------------------------------------------------------------------------------------
-------------------------------------------------------------------------------+---------------+-----------+----------+-------------+--------------------+---
--------------+------------------+---------------+------------------+---------------+---------------------------+---------------------------
  2 | admin | root@localhost.localdomain | 50a98aa2289b51e0d04033d6ed25baee71ec8adb9391a1387d165856be6a3b49cef64aa9f7b2e1203c9ed4d50d1dc45ebafc622c636fbd9c02
067f960c7b64ee1Mjm6hepV1u0jIQAAgnwzLGDnxVSvykApDObKofyZlR1ySggUXycJ1HUgclUv53V | Administrator |           |        5 |           0 |                  0 |   
              |                  |               |                  |               | 2012-08-03 11:01:26.79287 | 2012-08-03 11:01:26.79287
(1 row)

  
Actual results:
aeolus-configure fails to create admin user in first attempt,however its getting created after aeolus cleanup.

complete output:http://fpaste.org/rQvk/

Expected results:
aeolus-configure should create Admin user in the first attempt itslef.

Additional info:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.6.0-0.20120803040036git05a815a.fc16.noarch
aeolus-conductor-0.13.0-0.20120803080016git5403d2a.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120803080016git5403d2a.fc16.noarch
aeolus-all-0.13.0-0.20120803080016git5403d2a.fc16.noarch
aeolus-configure-2.8.0-0.20120803040031git5271be7.fc16.noarch
aeolus-conductor-doc-0.13.0-0.20120803080016git5403d2a.fc16.noarch
rubygem-aeolus-cli-0.7.0-0.20120803040033gitd64d64f.fc16.noarch
Comment 1 Dave Johnson 2012-08-06 16:21:52 EDT
fresh OS install
yum -y install aeolus-all
aeolus-configure -p ec2,mock

[root@hp-bl260cg5-01 yum.repos.d]# psql -U aeolus -d conductor -c "select count(*) from users where login='admin' "
 count 
-------
     1
(1 row)

[root@hp-bl260cg5-01 yum.repos.d]#

[root@hp-bl260cg5-01 yum.repos.d]# rpm -qa | grep aeolus | sort
aeolus-all-0.13.0-0.20120806160008gitc8e87f2.fc16.noarch
aeolus-conductor-0.13.0-0.20120806160008gitc8e87f2.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120806160008gitc8e87f2.fc16.noarch
aeolus-conductor-doc-0.13.0-0.20120806160008gitc8e87f2.fc16.noarch
aeolus-configure-2.8.0-0.20120806120023git5271be7.fc16.noarch
rubygem-aeolus-cli-0.7.0-0.20120806120025gitd64d64f.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120806120029git05a815a.fc16.noarch
[root@hp-bl260cg5-01 yum.repos.d]#

Note You need to log in before you can comment on or make changes to this bug.