Bug 845629 - Stackable subscriptions should be displayed in some type of hierarchy for a system
Stackable subscriptions should be displayed in some type of hierarchy for a s...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 11:48 EDT by Og Maciel
Modified: 2014-03-18 13:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:37:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHN portal (45.01 KB, image/png)
2012-08-03 11:49 EDT, Og Maciel
no flags Details
Subscriptions panel (45.73 KB, image/png)
2012-08-03 11:50 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2012-08-03 11:48:57 EDT
Description of problem:

If you have subscriptions for a product which are stackable, the Subscriptions panel for a registered system should show them grouped somehow in a hierarchy. For instance, you could have access to the following subscriptions:

Product Red Hat Enterprise Linux Server, Standard (1-2 sockets) (Up to 1 guest)
  Contract 001    Qty 3
Product Red Hat Enterprise Linux Server, Standard (1-2 sockets) (Up to 4 guest)
  Contract 002    Qty 3
Product Red Hat Enterprise Linux Server, Self-support (1-2 sockets) (Up to 1 
guest)
  Contract 003    Qty 3
  Contract 003    Qty 1

The Subscriptions panel "flattens" all of these subscriptions into a single level list, and it is hard to see that contract 003 is stackable. Could we somehow make it more obvious that 2 out of the 4 subscriptions are stackable?

Version-Release number of selected component (if applicable):

* candlepin-0.5.32-1.el6.noarch
* candlepin-tomcat6-0.5.32-1.el6.noarch
* katello-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-all-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.6-1.el6.noarch
* katello-cli-1.1.0-1.git.13.d10e8a3.el6_3.noarch
* katello-cli-common-1.1.0-1.git.13.d10e8a3.el6_3.noarch
* katello-common-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-configure-1.1.1-1.git.0.3794e67.el6_3.noarch
* katello-glue-candlepin-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-glue-foreman-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-glue-pulp-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.2.6-1.el6.noarch
* pulp-1.1.11-1.el6.noarch
* pulp-common-1.1.11-1.el6.noarch
* pulp-selinux-server-1.1.11-1.el6.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Og Maciel 2012-08-03 11:49:38 EDT
Created attachment 602162 [details]
RHN portal
Comment 2 Og Maciel 2012-08-03 11:50:07 EDT
Created attachment 602163 [details]
Subscriptions panel
Comment 3 Mike McCune 2014-03-18 13:37:21 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.