Bug 845638 - [RFE] Add Ability to define per Domain Default Shell
[RFE] Add Ability to define per Domain Default Shell
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.0
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
: FutureFeature
: 870062 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 12:47 EDT by Jenny Galipeau
Modified: 2014-06-17 23:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: sssd-1.10.0-1.el7.alpha1
Doc Type: Enhancement
Doc Text:
Feature: A new option, default_shell, was added to SSSD. Reason: Some environments, like Active Directory, do not have the shell attribute populated. Result (if any): Using the default_shell attribute, the administrator is able to set a UNIX shell for users coming from non-UNIX environments. The option can be set either globally or per-domain.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:46:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jenny Galipeau 2012-08-03 12:47:56 EDT
Description of problem:

Some domains like AD might not have a shell. For those cases there should be a way to set a default shell domain wide. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jakub Hrozek 2012-08-03 12:51:05 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1087
Comment 2 Jenny Galipeau 2012-08-03 12:52:10 EDT
Upstream Ticket

https://fedorahosted.org/sssd/ticket/1289
Comment 4 Jenny Galipeau 2013-03-13 11:28:10 EDT
*** Bug 870062 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Hrozek 2013-03-26 14:04:55 EDT
Fixed upstream.
Comment 6 Jakub Hrozek 2013-10-04 09:22:59 EDT
Temporarily moving bugs to MODIFIED to work around errata tool bug
Comment 8 Amith 2014-02-06 07:41:13 EST
Verified RFE on SSSD Version: sssd-1.11.2-37.el7.x86_64

All test cases PASSED and automated. A minor man page bug was logged, see: https://bugzilla.redhat.com/show_bug.cgi?id=1059253
Comment 9 Ludek Smid 2014-06-13 05:46:20 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.