Bug 845684 - ypserv does not respond to ypbind broadcast request
ypserv does not respond to ypbind broadcast request
Status: CLOSED DUPLICATE of bug 829475
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ypserv (Show other bugs)
6.3
x86_64 Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Honza Horak
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 16:51 EDT by Joshua Weage
Modified: 2012-08-09 07:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 07:28:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Weage 2012-08-03 16:51:55 EDT
Description of problem:
ypserv does not respond to broadcast requests from ypbind. ypserv sees the broadcast request, but reports the localhost IP address rather than the client address.


Version-Release number of selected component (if applicable):
2.19.22.el6

How reproducible:
Always

Steps to Reproduce:
1. Install ypserv and ypbind.
2. Configure NISDOMAIN in /etc/sysconfig/network
3. Start ypserv
4. /usr/lib64/yp/ypinit -m
5. Restart ypserv
6. Run ypbind -d
  
Actual results:
Output from ypserv -d:

[root@nis1 ~]# ypserv -d
[ypserv (ypserv) 2.19]

Find securenet: 255.255.255.255 127.0.0.1
Find securenet: 255.255.255.0 192.168.2.0
ypserv.conf: dns: 0
ypserv.conf: files: 30
ypserv.conf: xfr_check_port: 1
ypserv.conf: 0.0.0.0/0.0.0.0:*:shadow.byname:2
ypserv.conf: 0.0.0.0/0.0.0.0:*:passwd.adjunct.byname:2
ypproc_domain_nonack("ansa-usa.com") [From: 127.0.0.1:779]
connect from 127.0.0.1
        -> OK.
ypproc_domain_nonack("ansa-usa.com") [From: 127.0.0.1:779]
connect from 127.0.0.1
        -> OK.
ypproc_domain_nonack("ansa-usa.com") [From: 127.0.0.1:779]
connect from 127.0.0.1
        -> OK.
ypproc_domain_nonack("ansa-usa.com") [From: 127.0.0.1:779]
connect from 127.0.0.1
        -> OK.
ypproc_domain_nonack("ansa-usa.com") [From: 127.0.0.1:779]
connect from 127.0.0.1
        -> OK.

Output from ypbind -d:
[jweage@viper4 yp]$ sudo ypbind -d
4894: parsing config file
4894: No entry found.
4894: add_server() domain: ansa-usa.com, broadcast
4894: [Welcome to ypbind-mt, version 1.19]

4894: ping interval is 20 seconds

4896: do_broadcast() for domain 'ansa-usa.com' is called
4894: ypbindproc_domain_2_svc (ansa-usa.com)
4895: Signal (2) for quitting program arrived.

Expected results:


Additional info:
Same bug reported against Fedora here: https://bugzilla.redhat.com/show_bug.cgi?id=781880
Comment 2 Honza Horak 2012-08-09 07:28:26 EDT
This is actually a bug in libtirpc component and is already reported against RHEL-6, so marking as duplicate. Feel free to join the conversation in bug #829475.

*** This bug has been marked as a duplicate of bug 829475 ***

Note You need to log in before you can comment on or make changes to this bug.