Bug 845705 - Anaconda forces install of program in group
Anaconda forces install of program in group
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 18:58 EDT by Tom
Modified: 2013-01-10 01:52 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-03 19:28:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom 2012-08-03 18:58:16 EDT
Description of problem:
Intalling Rawhide using F17 install DVD forces install of Shotwell from the Graphics group.

Version-Release number of selected component (if applicable):
http://download.fedoraproject.org/pub/fedora/linux/releases/17/Fedora/x86_64/iso/Fedora-17-x86_64-DVD.iso downloaded yesterday.

How reproducible:
Everytime

Steps to Reproduce:
1.Change repo in Anaconda on F17 install DVD for Rawhide.
2.Anaconda checks dependencies, and Shotwell is broken.
3.Unselect Shotwell in Graphics group, but unable to stop Shotwell from being installed with broken dependencies.
  
Actual results:
Forced install of Shotwell in Anaconda, even after unselecting.

Expected results:
Can unselect any program without having to unselect it's entire group.

Additional info:
Comment 1 Jesse Keating 2012-08-03 19:28:14 EDT
Unchecking a software package does not completely exclude it from the installation.  It may be brought back in via a dependency from another package you have selected.

In the logs or on screen there should be some hints as to what is requiring shotwell, but I'm going to close this as not a bug.
Comment 2 Tom 2012-08-04 09:34:23 EDT
I can remove Shotwell by itself in yum after the install.
Comment 3 Vratislav Podzimek 2012-08-07 08:03:28 EDT
(In reply to comment #1)
> In the logs or on screen there should be some hints as to what is requiring
> shotwell, but I'm going to close this as not a bug.
/var/log/anaconda/anaconda.yum.log (on the installed system) may contain some hint. But how did you install the system if shotwell had broken dependencies?
Comment 4 Tom 2012-08-07 15:23:52 EDT
I only saw this in the Anaconda logs for Shotwell:
 DEBUG   : package shotwell-0.12.3-1.fc18.x86_64 was not marked in group graphics
 
 DEBUG   : TSINFO: Marking unique3-3.0.2-4.fc18.x86_64 as install for shotwell-0.12.3-1.fc18.x86_64
 DEBUG   : TSINFO: Marking rest-0.7.12-3.fc18.x86_64 as install for shotwell-0.12.3-1.fc18.x86_64
 DEBUG   : TSINFO: Marking LibRaw-0.14.6-3.fc18.x86_64 as install for shotwell-0.12.3-1.fc18.x86_64

 WARN anaconda: shotwell-0.12.3-1.fc18.x86_64 requires libgphoto2.so.2()(64bit)
 WARN anaconda: shotwell-0.12.3-1.fc18.x86_64 requires libgphoto2_port.so.0()(64bit)

Ananconda forced Shotwell install after giving a warning.

Note You need to log in before you can comment on or make changes to this bug.