Bug 845730 - Sytem won't boot after software update 2.th august
Sytem won't boot after software update 2.th august
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-04 05:37 EDT by Olav S. Flaa
Modified: 2013-01-02 08:22 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 08:22:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olav S. Flaa 2012-08-04 05:37:53 EDT
Description of problem:
Fedora unable to boot/start after updating all software 2.th august. I ran "sudo yum update" the 1.th august. The next time I booted the PC, everything worked perfectly. I also ran "sudo yum update" at 2.th august. After this my PC won't boot at all any more. The boot process starts as it should, but after some seconds nothing more happens. And I get no error message on the screen. It doesn't help to try to boot in "basic graphics mode" either. I then have to press and hold the power-button on my computer down for some seconds to shut it down. I have tried to reinstall Fedora completely in a new partion on the harddrive and have no problem to shut it down and then boot it. It works perfect. But as soon as I update the software by typing "sudo yum update" it becomes unable to boot again the next time.

How reproducible:
Turn on the computer, it happens every time.

Additional info:
I use a ASUS Eee PC 1215N with Intel® Atom™ CPU N2800 @ 1.86GHz × 4, Gallium 0.4 on llvmpipe (LLVM 0x300) graphics driver, and a 32-bit version.
Comment 1 Olav S. Flaa 2012-12-01 04:13:16 EST
I have used Fedora 17 without doing any updates of my system after installation since august. But about a week ago I tried to run "yum update" again just to see if anything had changed. Now the system boots as it should even after the update. So the problem seems to be solved for a unknown reason :-)
Comment 2 Dirk Hoffmann 2012-12-20 03:42:22 EST
I have a similar problem on a DELL Latitude E6430, installed fc17_x86_64 a month ago, then updated packages. 

The present most recent kernel, 3.6.9-2, fails intermittently (with a 5 out of 7 chance) to boot. If unattended, it is just stuck in the plymouth splash screen. If I disable the plymouth screen at the beginning of the boot, then I see the last messages

 Starting Bluetooth Manager
 Starting OpenSSH
 Starting RPC bind

before the system is completely stuck (No Ctrl-Alt-Del, Ctrl-Alt-anything) and needs a hard power down.

Difficult to say which of the services is the faulty one. They seem to be booting in parallel (on the 8-core CPU), and I am not familiar enough with the new (kernel 3?) system services management. Otherwise I would temporarily disable them to find out. /etc/rc?.d does not seem to be the only place to configure this any more.

If someone could point me to the right method, I would be glad to provide more input.

The previous kernel (3.3.4-5) boots without problems.
Comment 3 Josh Boyer 2013-01-02 08:22:08 EST
Closing this out as the original reporter is no longer seeing the issue.  Dirk, you have different hardware.  Please open a new bug if you are still having troubles.

Note You need to log in before you can comment on or make changes to this bug.