Bug 845766 - Fedora can't detect Yota USB router which plugged via usb. On Windows it detected as Ethernet over USB device.
Fedora can't detect Yota USB router which plugged via usb. On Windows it dete...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-04 14:48 EDT by Mikhail
Modified: 2013-05-01 13:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-01 13:48:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
device id in windows (415.42 KB, image/png)
2012-08-04 14:48 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2012-08-04 14:48:22 EDT
Created attachment 602269 [details]
device id in windows

Description of problem:
Fedora can't detect Yota USB router which plugged via usb. On Windows it detected as Ethernet over USB device.

Dmesg output:
[28604.750034] usb 1-3: new high-speed USB device number 10 using ehci_hcd
[28604.867736] usb 1-3: New USB device found, idVendor=0408, idProduct=d00a
[28604.867742] usb 1-3: New USB device strings: Mfr=3, Product=2, SerialNumber=4
[28604.867745] usb 1-3: Product: Yota Router LTE Technologies
[28604.867749] usb 1-3: Manufacturer: Yota Router
[28604.867751] usb 1-3: SerialNumber: 1234567890ABCDEF
[28604.870468] scsi14 : usb-storage 1-3:1.3
[28605.874045] scsi 14:0:0:0: CD-ROM            QDL      Mass storage     2.31 PQ: 0 ANSI: 2
[28605.877761] sr1: scsi-1 drive
[28605.878210] sr 14:0:0:0: Attached scsi CD-ROM sr1
[28605.878418] sr 14:0:0:0: Attached scsi generic sg3 type 5

Also I couldn't see CD-ROM which must appear after I plug this device.
Comment 1 Neil Horman 2013-05-01 13:48:06 EDT
the device in question isn't supported by Linux.  That vendor id shows up as part of the qmi_wwan driver, but it doesn't list that device id as having support.  The CDrom device does appear to be showing up from what you have above (its registered as sg3, so you should be able to mount /dev/sg3 to get the storage contents there).

However thats moot since it doesnt seem that you have a driver.  You'll need to try get support added from YOTA directly, as they don't seem to publish much in the way of developer documentation.

Note You need to log in before you can comment on or make changes to this bug.