Bug 845864 - [RFE] Add optional --placement parameter to numatune command.
[RFE] Add optional --placement parameter to numatune command.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Osier Yang
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-05 21:13 EDT by hongming
Modified: 2012-09-17 10:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 10:29:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hongming 2012-08-05 21:13:35 EDT
Description of problem:
The numatune command can get or set the "mode" and "nodeset" parameters for a guest domain. But it is unable to set or get the "placement" parameter.The customers may have the request for virsh to tune the memory placement for domain process.  

Quote as follows from libvirt.org http://libvirt.org/formatdomain.html#elementsNUMATuning

Attribute placement (since 0.9.12) can be used to indicate the memory placement mode for domain process, its value can be either "static" or "auto", 
defaults to placement of vcpu, or "static" if nodeset is specified. "auto" indicates the domain process will only allocate memory from the advisory 
nodeset returned from querying numad, and the value of attribute nodeset will be ignored if it's specified.
If placement of vcpu is 'auto', and numatune is not specified, a default numatune with placement 'auto' and mode 'strict' will be added implicitly.




Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.# virsh dumpxml rhel6q 

  <vcpu placement='auto'>10</vcpu>
  <numatune>
    <memory mode='strict' placement='auto'/>
  </numatune>


2.# virsh numatune rhel6q
numa_mode      : strict
numa_nodeset   : 1

3.
  
Actual results:
The numatune command is unable to set and get the placement parameter.


Expected results:
The numatune command is able to set and get the placement parameter.

Additional info:
Comment 2 Osier Yang 2012-08-17 03:51:46 EDT
(In reply to comment #0)
> Description of problem:
> The numatune command can get or set the "mode" and "nodeset" parameters for
> a guest domain. But it is unable to set or get the "placement" parameter.The
> customers may have the request for virsh to tune the memory placement for
> domain process.  

IMO we should NACK this request, because the numatune command is based on cgroup
setting, however, the "placement" is for numad. It shouldn't be mixed together
further any more. We already suffering from the mess (share same XML syntax for
two underlying entries of one same driver). On the other hand, "placement"
tuning doesn't make any sense for a running domain.

Note You need to log in before you can comment on or make changes to this bug.