Bug 845877 - [patch] maven-archetype fails to build from source. OSGI info for catalog.jar
[patch] maven-archetype fails to build from source. OSGI info for catalog.jar
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: maven-archetype (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-05 22:05 EDT by Gerard Ryan
Modified: 2012-08-07 05:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 05:38:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix-jetty-namespace-Add-OSGI-manifest-to-catalog.jar (13.75 KB, patch)
2012-08-05 22:05 EDT, Gerard Ryan
no flags Details | Diff
use pom macros to inject OSGI info instead of hand-carving it (13.06 KB, patch)
2012-08-06 19:34 EDT, Gerard Ryan
no flags Details | Diff

  None (edit)
Description Gerard Ryan 2012-08-05 22:05:19 EDT
Created attachment 602399 [details]
Fix-jetty-namespace-Add-OSGI-manifest-to-catalog.jar

Description of problem:
1. FTBFS
2. I'm building eclipse-m2e, and it needs catalog.jar from this package to have OSGI info.

Additional info:
The mass rebuild[1] shows that this package is broken. The problem is that jetty has a new namespace since this was last built. All references to jetty have been updated.

I've added some handmade OSGI information to catalog.jar. I think it's okay, but it probably should be checked! It works for my needs at least.

Builds successfully for F18[2] and F17[3].


[1] http://koji.fedoraproject.org/koji/packageinfo?packageID=12612
[2] http://koji.fedoraproject.org/koji/taskinfo?taskID=4361812
[3] http://koji.fedoraproject.org/koji/taskinfo?taskID=4361836
Comment 1 Gerard Ryan 2012-08-06 19:34:09 EDT
Created attachment 602603 [details]
use pom macros to inject OSGI info instead of hand-carving it

I've modified the patch so that the OSGI info is added by maven-plugin-bundle, added with pom macros,
Comment 2 Gerard Ryan 2012-08-06 19:57:05 EDT
I'm not sure if OSGI info should be added for all jars: I didn't think of it at the time, but with maven-plugin-bundle it would be straightforward I imagine.
Comment 3 Stanislav Ochotnicky 2012-08-07 05:38:36 EDT
We'll see about addition of this for all jars. I'll file an upstream bug

Patch applied with a few more changes on top to cleanup export information

Note You need to log in before you can comment on or make changes to this bug.