Bug 8459 - Init fails to call shutdown scripts
Summary: Init fails to call shutdown scripts
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-14 00:24 UTC by ts_jones
Modified: 2014-03-17 02:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-01 22:40:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ts_jones 2000-01-14 00:24:33 UTC
init fails to call shutdown scripts when changing run levels to 6 or 0.

I have created a script to start and shutdown a database server.  I have
placed the script in init.d, set the correct permissions and mode.  Have
tested it at the shell level and it works fine.  I have installed with
both chkconfig and tksysv with the same effect.  Init calls the script
fine at startup i.e calls it with the "start" parameter, fails to call it
with the "stop" parameter when switching to run level 0 or 6.  I find it
very unusual since other "system" scripts get called fine at shutdown.  I
have searched the news groups to find many other's with the same problem.
I have check all the links of the K* scripts and they seem to be fine.  Is
there perhaps some special way of "registering" a script that has been
left out of the documentation?

Todd Jones ts_jones@cyberhighway.net

Comment 1 Bill Nottingham 2000-01-21 06:15:59 UTC
What does your script look like, and what links do you have for it?

Comment 2 Bill Nottingham 2000-02-01 22:40:59 UTC
Hm... oh, you mean the SysVinit maintainer; yes, he's
a Debian person. I believe the correct documentation
for writing init files should be in sysvinitfiles, in
/usr/doc/initscripts-<version>.


Note You need to log in before you can comment on or make changes to this bug.