Bug 845933 - Two soft link of files are broken.
Two soft link of files are broken.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Dan Mace
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 03:35 EDT by xjia
Modified: 2015-05-14 18:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: libra_ami 1977+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:28:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xjia 2012-08-06 03:35:17 EDT
Description of problem:
The soft link of these files are broken. 

/usr/libexec/stickshift/cartridges/embedded/phpmyadmin-3.4/info/connection-hooks/set-db-connection-info

/usr/libexec/stickshift/cartridges/jbosseap-6.0/info/hooks/preconfigure

Version-Release number of selected component (if applicable):
dev_env_1940

How reproducible:
always

Steps to Reproduce:
1.via the instance
2.ll  /usr/libexec/stickshift/cartridges/embedded/phpmyadmin-3.4/info/connection-hooks/set-db-connection-info
3.ll /usr/libexec/stickshift/cartridges/jbosseap-6.0/info/hooks/preconfigure
  
Actual results:

[root@ip-10-224-115-241 /]# ll  /usr/libexec/stickshift/cartridges/embedded/phpmyadmin-3.4/info/connection-hooks/set-db-connection-info
lrwxrwxrwx. 1 root root 115 Aug  5 01:44 /usr/libexec/stickshift/cartridges/embedded/phpmyadmin-3.4/info/connection-hooks/set-db-connection-info -> /usr/libexec/stickshift/cartridges/embedded/phpmyadmin-3.4/../abstract/info/connection-hooks/set-db-connection-info

The path "/usr/libexec/stickshift/cartridges/embedded/phpmyadmin-3.4/../abstract/info/connection-hooks/set-db-connection-info" is wrong.

[root@ip-10-224-115-241 /]# ll /usr/libexec/stickshift/cartridges/jbosseap-6.0/info/hooks/preconfigure
lrwxrwxrwx. 1 root root 83 Aug  5 01:44 /usr/libexec/stickshift/cartridges/jbosseap-6.0/info/hooks/preconfigure -> /usr/libexec/stickshift/cartridges/jbosseap-6.0/../abstract/info/hooks/preconfigure

The file 'preconfigure' is not exist under /usr/libexec/stickshift/cartridges/abstract/info/hooks/ dir


Expected results:
Step 2:
The path should be "/usr/libexec/stickshift/cartridges/embedded/phpmyadmin-3.4/../../abstract/info/connection-hooks/set-db-connection-info"
Step 3:
Add a file 'preconfigure' under  /usr/libexec/stickshift/cartridges/abstract/info/hooks/ dir 

Additional info:
none
Comment 1 Xiaoli Tian 2012-08-06 06:08:26 EDT
Reduce severity to low, since phpmyadmin could conncet to mysql successfully , jbosseap app could be created successfully, and it will not affect most users.
Comment 2 Dan Mace 2012-08-13 17:32:13 EDT
Resolved by https://github.com/openshift/crankcase/pull/366
Comment 3 xjia 2012-08-14 22:55:44 EDT
Verify.
The broken symlinks has been fixed.

Note You need to log in before you can comment on or make changes to this bug.