Bug 845947 - webadmin: cannot import a vm based on template when the template does not exist in the setup even with collapse snapshots
webadmin: cannot import a vm based on template when the template does not exi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.1.0
x86_64 Linux
urgent Severity high
: ---
: 3.1.0
Assigned To: Gilad Chaplik
Dafna Ron
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 04:26 EDT by Dafna Ron
Modified: 2016-02-10 11:57 EST (History)
10 users (show)

See Also:
Fixed In Version: si18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:00:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (112.96 KB, image/jpeg)
2012-09-05 05:44 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-06 04:26:08 EDT
Description of problem:

We cannot import a vm based on template when the target template does not exist in setup even when we tag the collapse snapshots box. 
also, there is no error presented in the UI. the dialogue will simply not close when we press OK. 

Version-Release number of selected component (if applicable):

si13

How reproducible:

100%

Steps to Reproduce:
1. try to import a vm based on template when the setup does not have the template. try with and without collapse snapshots. 
2.
3.
  
Actual results:

we cannot import the vm with no errors/warning in the dialogue

Expected results:

we should be able to import the vm once we check the collapse box. 

Additional info:
Comment 1 Ayal Baron 2012-08-08 04:56:49 EDT
Does the template exist on the export domain? if not then it indeed should fail.
Comment 2 Dafna Ron 2012-08-08 06:42:08 EDT
1. if the template exists in the target domain (which is not the export) than it should not fail. if the template does not exist in the target domain (which it doesn't than yes, it should fail unless we select the collapse snapshot box and in which case the export should succeed. 
2. the UI shows no failure. we simply press the OK button and nothing happens.
Comment 4 Gilad Chaplik 2012-08-19 05:26:52 EDT
pushed upstream (http://gerrit.ovirt.org/#/c/7313/)
Comment 6 Dafna Ron 2012-09-05 05:44:16 EDT
Created attachment 609953 [details]
screen shot

tested in si17

although I have a nice warning when I choose the collapse I still cannot import the vm since the OK button is missing from the dialogue.
Comment 7 Gilad Chaplik 2012-09-06 09:19:56 EDT
in gerrit (http://gerrit.ovirt.org/#/c/7815/)
Comment 11 Dafna Ron 2012-09-16 04:19:03 EDT
verified on si18

Note You need to log in before you can comment on or make changes to this bug.