Bug 845967 - quickstart : failed to deploy reviewboard example
quickstart : failed to deploy reviewboard example
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 06:32 EDT by Meng Bo
Modified: 2015-05-14 22:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-08-06 06:32:22 EDT
Description of problem:
https://github.com/openshift/reviewboard-example

Version-Release number of selected component (if applicable):
stage

How reproducible:
always

Steps to Reproduce:
1.Follow the step in the github
2.
3.
  
Actual results:
Internal Server Error page shows after git push.

Expected results:
Reviewboard should be deployed successfully.

Additional info:
Output snip:

remote: Installed /var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/python-2.6/virtenv/lib/python2.6/site-packages/django_evolution-0.6.7-py2.6.egg
remote: Searching for Django==1.3.3
remote: Reading http://mirror1.stg.rhcloud.com/mirror/python/web/simple/Django/
remote: Reading http://www.djangoproject.com/
remote: No local packages or download links found for Django==1.3.3
remote: Best match: None
remote: Traceback (most recent call last):
remote:   File "/var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/app-root/runtime/repo/setup.py", line 9, in <module>
remote:     install_requires=['ReviewBoard'],
remote:   File "/usr/lib64/python2.6/distutils/core.py", line 152, in setup
remote:     dist.run_commands()
remote:   File "/usr/lib64/python2.6/distutils/dist.py", line 975, in run_commands
remote:     self.run_command(cmd)
remote:   File "/usr/lib64/python2.6/distutils/dist.py", line 995, in run_command
remote:     cmd_obj.run()
remote:   File "build/bdist.linux-i686/egg/setuptools/command/develop.py", line 27, in run
remote:   File "build/bdist.linux-i686/egg/setuptools/command/develop.py", line 102, in install_for_development
remote:   File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 519, in process_distribution
remote:     
remote:   File "build/bdist.linux-i686/egg/pkg_resources.py", line 563, in resolve
remote:     distributions, errors = working_set.find_plugins(
remote:   File "build/bdist.linux-i686/egg/pkg_resources.py", line 799, in best_match
remote:     
remote:   File "build/bdist.linux-i686/egg/pkg_resources.py", line 811, in obtain
remote:     raise TypeError("Can't add %r to environment" % (other,))
remote:   File "build/bdist.linux-i686/egg/setuptools/command/easy_install.py", line 434, in easy_install
remote:     
remote:   File "build/bdist.linux-i686/egg/setuptools/package_index.py", line 475, in fetch_distribution
remote: AttributeError: 'NoneType' object has no attribute 'clone'
remote: Making script /var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/rb-site relative
remote: Making script /var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/easy_install relative
remote: Script /var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/activate.fish cannot be made relative (it's not a normal script that starts with #!/var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/python)
remote: Making script /var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/rbssh relative
remote: Making script /var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/pip-2.6 relative
remote: Script /var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/activate.csh cannot be made relative (it's not a normal script that starts with #!/var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/python)
remote: Making script /var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/pygmentize relative
remote: Making script /var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/easy_install-2.6 relative
remote: Making script /var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/pip relative
remote: Running .openshift/action_hooks/build
remote: Running .openshift/action_hooks/deploy
remote: Traceback (most recent call last):
remote:   File "/var/lib/stickshift/94de5c92adb2436a873be3fe9e1937ad/reviewboard/virtenv/bin/rb-site", line 6, in <module>
remote:     from pkg_resources import load_entry_point
remote:   File "build/bdist.linux-i686/egg/pkg_resources.py", line 2603, in <module>
remote:     """Split a string or iterable thereof into (section,content) pairs
remote:   File "build/bdist.linux-i686/egg/pkg_resources.py", line 666, in require
remote:     for callback in self.callbacks:
remote:   File "build/bdist.linux-i686/egg/pkg_resources.py", line 565, in resolve
remote:     )
remote: pkg_resources.DistributionNotFound: Django==1.3.3
Comment 1 Ram Ranganathan 2012-08-06 17:45:52 EDT
Hmm, seems weird that this works on prod and fails on stage. 
Does adding "Django==1.3.3" in the install_requires line work for you?? 

If it does, then something in the setup.py mechanism is not correct or possibly a bug therein.  And we could probably change the quickstart to add that in for now.
Comment 2 Ram Ranganathan 2012-08-06 18:42:57 EDT
this is a STG only bug -- because the package is not available on stage mirror. On prod, this package will get pulled in from http://pypi.python.org/pypi/Django and will be installed correctly. 

Lowering the severity as this is only on STG. Seems odd that we have a partial list of packages in the STG mirror --  http://mirror1.stg.rhcloud.com/mirror/python/web/simple
Comment 3 Meng Bo 2012-08-06 21:54:50 EDT
After adding the 'Django==1.3.3' to install_requires in the setup.py, the deployment got the same result, and failed.

Then I tried to deploy a django example from github, and found the following output:
remote: Installed /var/lib/stickshift/09ccba83b4294b39a2ace076eb56aed3/python-2.6/virtenv
remote: Processing dependencies for YourAppName==1.0
remote: Searching for Django>=1.3
remote: Reading http://mirror1.stg.rhcloud.com/mirror/python/web/simple/Django/
remote: Reading http://www.djangoproject.com/
remote: Best match: Django 1.4
remote: Downloading https://www.djangoproject.com/m/releases/1.4/Django-1.4.tar.gz
remote: Processing Django-1.4.tar.gz
remote: Running Django-1.4/setup.py -q bdist_egg --dist-dir /tmp/easy_install-bmWLZp/Django-1.4/egg-dist-tmp-KgWSj8

It means the newer version of django can be found on the stage mirror.

Then I added the ['Django>=1.3] to install_requires and tried again.

The deployment still failed by the following output:
remote: Installed /var/lib/stickshift/322cba6c3015487c9a2a3052fabdf0c2/python-2.6/virtenv/lib/python2.6/site-packages/django_evolution-0.6.7-py2.6.egg
remote: error: Installed distribution Django 1.4 conflicts with requirement Django==1.3.3
<-----snip----->
remote: Traceback (most recent call last):
remote:   File "/var/lib/stickshift/322cba6c3015487c9a2a3052fabdf0c2/reviewboard/virtenv/bin/rb-site", line 6, in <module>
remote:     from pkg_resources import load_entry_point
remote:   File "build/bdist.linux-i686/egg/pkg_resources.py", line 2607, in <module>
remote:     comment-only lines.  If there are any such lines before the first section
remote:   File "build/bdist.linux-i686/egg/pkg_resources.py", line 565, in resolve
remote:     )
remote: pkg_resources.DistributionNotFound: Django==1.3.3
Comment 4 Ram Ranganathan 2012-08-07 13:09:58 EDT
Meng, the stg mirror has only a subset of packages -- specifically Django 1.3.3 is not there.  Prod works fine as it doesn't use the mirror. The fix will be to check w/ tdawson once he's back on the mirrors and accordingly use/don't use 'em.
Comment 5 Ram Ranganathan 2012-10-18 18:24:35 EDT
There were 2 issues -- one was the mirrors were fixed -- the other is the issue w/ the quickstart -- has been fixed now. Please retest using the dev/typeless branch of the quickstart.
Comment 6 Attila Nagy 2012-10-22 07:18:43 EDT
Verified against devenv_2360

Note You need to log in before you can comment on or make changes to this bug.